Bug 1819548 - pod failed to communicate to itself [NEEDINFO]
Summary: pod failed to communicate to itself
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 1819876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-01 03:09 UTC by Rajnikant
Modified: 2020-07-24 09:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes Only
Doc Text:
Important: if this rebase also contains *enhancements* (or contains only enhancements), select the correct option from the Doc Type drop-down list. Rebase package(s) to version: OVS/OVN bumped to 2.13 Highlights and important bug fixes: Fixed hairpin mode (so a pod can talk to itself through a service)
Clone Of:
Environment:
Last Closed: 2020-07-13 17:24:43 UTC
Target Upstream Version:
augol: needinfo? (rkant)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:25:14 UTC

Description Rajnikant 2020-04-01 03:09:17 UTC
Description of problem:
pod failed to communicate to itself

Version-Release number of selected component (if applicable):
Server Version: 4.3.5

How reproducible:


  status:
    clusterNetwork:
..
    networkType: OVNKubernetes

pod to itself communication was failing with connection timeout. 

* connect to 172.30.x.x port 80 failed: Connection timed out

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Ben Bennett 2020-04-01 14:12:26 UTC
Setting the target to 4.5.  We will make backport decisions once the bug is understood.

Comment 8 zhaozhanqi 2020-04-21 06:17:56 UTC
Tested this issue on 4.3.0-0.nightly-2020-04-20-084750, this should be working, see:

 $oc create -f list_for_pods.json 
replicationcontroller/test-rc created
service/test-service created
$ oc get svc
NAME           TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)     AGE
test-service   ClusterIP   172.30.113.135   <none>        27017/TCP   5s
$ oc get pod
NAME            READY   STATUS    RESTARTS   AGE
test-rc-5ql59   1/1     Running   0          9s
test-rc-8b77h   1/1     Running   0          9s
$ oc rsh test-rc-5ql59
~ $ curl test-service:27017
Hello OpenShift!

Comment 11 errata-xmlrpc 2020-07-13 17:24:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.