Bug 1819571 - `oc explain network-attachment-definitions` returns empty description
Summary: `oc explain network-attachment-definitions` returns empty description
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Douglas Smith
QA Contact: huirwang
URL:
Whiteboard: SDN-CI-IMPACT
Depends On:
Blocks: 1823711 1861412
TreeView+ depends on / blocked
 
Reported: 2020-04-01 05:38 UTC by huirwang
Modified: 2020-10-27 15:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1823709 1861412 (view as bug list)
Environment:
Last Closed: 2020-10-27 15:57:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 729 0 None closed Bug 1819571: NetworkAttachmentDefinitions should have output for "oc explain" 2020-09-21 14:56:10 UTC
Github openshift cluster-network-operator pull 745 0 None closed Bug 1819571: NetworkAttachmentDefinitions should have output for "oc explain" 2020-09-21 14:56:10 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:12 UTC

Description huirwang 2020-04-01 05:38:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):
 4.5.0-0.nightly-2020-03-30-174407 

How reproducible:
Always

Steps to Reproduce:


oc explain network-attachment-definitions
KIND:     NetworkAttachmentDefinition
VERSION:  k8s.cni.cncf.io/v1

DESCRIPTION:
     <empty>




Expected results:
Should return detailed description information and related fields explanation.

Additional info:

Comment 3 Ben Bennett 2020-05-08 20:26:36 UTC
@doug -- Any updates?  Thanks

Comment 8 Tomofumi Hayashi 2020-07-28 03:18:13 UTC
upstream PR: https://github.com/intel/multus-cni/pull/541

Comment 9 Douglas Smith 2020-07-31 13:38:18 UTC
downstream PR @ https://github.com/openshift/cluster-network-operator/pull/729

Comment 12 Weibin Liang 2020-08-03 17:14:25 UTC
Fix is not in latest v4.6 nightly image yet

[weliang@weliang tools]$ oc explain network-attachment-definitions
KIND:     NetworkAttachmentDefinition
VERSION:  k8s.cni.cncf.io/v1

DESCRIPTION:
     <empty>
[weliang@weliang tools]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-08-03-091920   True        False         3h41m   Cluster version is 4.6.0-0.nightly-2020-08-03-091920
[weliang@weliang tools]$

Comment 13 Tomofumi Hayashi 2020-08-05 05:44:30 UTC
Weibin, acked. Now I propose additional fix for that.

Comment 15 Weibin Liang 2020-08-13 14:26:01 UTC
[weliang@weliang verification-tests]$ oc get clusterversions
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-08-13-091737   True        False         6m26s   Cluster version is 4.6.0-0.nightly-2020-08-13-091737
[weliang@weliang verification-tests]$ oc explain network-attachment-definitions
KIND:     NetworkAttachmentDefinition
VERSION:  k8s.cni.cncf.io/v1

DESCRIPTION:
     NetworkAttachmentDefinition is a CRD schema specified by the Network
     Plumbing Working Group to express the intent for attaching pods to one or
     more logical or physical networks. More information available at:
     https://github.com/k8snetworkplumbingwg/multi-net-spec

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object>
     NetworkAttachmentDefinition spec defines the desired state of a network
     attachment

[weliang@weliang verification-tests]$

Comment 17 errata-xmlrpc 2020-10-27 15:57:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.