Bug 1819590 - [IPI on BM] Filter events with BMH type no matching events displayed
Summary: [IPI on BM] Filter events with BMH type no matching events displayed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Yadan Pei
QA Contact: Udi Kalifon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-01 06:56 UTC by Yadan Pei
Modified: 2020-10-27 15:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:57:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Filter Events with Deployment type (488.57 KB, image/png)
2020-04-01 06:58 UTC, Yadan Pei
no flags Details
Check Events When Resource type is all (285.59 KB, image/png)
2020-04-01 06:59 UTC, Yadan Pei
no flags Details
Filter Events with BMH type (185.83 KB, image/png)
2020-04-01 07:00 UTC, Yadan Pei
no flags Details
Namespace Events shown when resource type all (380.06 KB, image/png)
2020-04-01 08:42 UTC, Yadan Pei
no flags Details
No Matching Events when resource type is NS (141.35 KB, image/png)
2020-04-01 08:43 UTC, Yadan Pei
no flags Details
Filter Events with BMH type Resutls Shown (433.60 KB, image/png)
2020-09-28 09:50 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:12 UTC

Description Yadan Pei 2020-04-01 06:56:18 UTC
Description of problem:
When filter events with BMH type, no matching events 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-31-053841

How reproducible:
Always

Steps to Reproduce:
1. Power off and Power on one bare metal hosts from console Compute -> Bare Metal Hosts
2. Check events in openshift-machine-api with Resources type with All
3. Filter events with Resource type 'BMH'

Actual results:
2. Show events about BMH
3. Showing 0 events
No matching events
events exist, but none match the current filter

Expected results:
3. Since there are BMH events in this project, so when we filter using BMH type, events should be displayed correctly it still show 0 events even we wait for longer time(sometimes events loading may cost several seconds )

Additional info:

Comment 1 Yadan Pei 2020-04-01 06:58:52 UTC
Created attachment 1675309 [details]
Filter Events with Deployment type

Comment 2 Yadan Pei 2020-04-01 06:59:57 UTC
Created attachment 1675310 [details]
Check Events When Resource type is all

Comment 3 Yadan Pei 2020-04-01 07:00:35 UTC
Created attachment 1675311 [details]
Filter Events with BMH type

Comment 4 Yadan Pei 2020-04-01 08:41:05 UTC
Filter with Namespace type also don't return events related with namespace

Comment 5 Yadan Pei 2020-04-01 08:42:06 UTC
Created attachment 1675319 [details]
Namespace Events shown when resource type all

Comment 6 Yadan Pei 2020-04-01 08:43:57 UTC
Created attachment 1675320 [details]
No Matching Events when resource type is NS

Comment 7 Tomas Jelinek 2020-05-29 08:30:08 UTC
Unfortunately there was no capacity this sprint to do this. Moving to upcoming.

Comment 10 Rastislav Wagner 2020-09-17 09:44:42 UTC
works fine on latest version, can you verify ?

Comment 11 Yadan Pei 2020-09-28 09:50:14 UTC
Created attachment 1717231 [details]
Filter Events with BMH type Resutls Shown

Checked on 4.6.0-0.nightly-2020-09-27-075304, Home -> Events page, when searching with Resource: BMH, the baremetal hosts events are shown correctly

Comment 14 errata-xmlrpc 2020-10-27 15:57:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.