Bug 181960 - The bell/alarm character produces no sound when sent to a console terminal
The bell/alarm character produces no sound when sent to a console terminal
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 17:54 EST by arch harris
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 11:10:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description arch harris 2006-02-17 17:54:13 EST
Description of problem:
  When sent to a console terminal, the bell/alarm character does not produce any
  sound.

Version-Release number of selected component (if applicable):


How reproducible:
  Everytime


Steps to Reproduce:
1. Execute: echo -e '\a'
2.
3.
  
Actual results:
  No sound

Expected results:
  A beep sound

Additional info:
Comment 2 Neil Horman 2006-05-04 10:05:30 EDT
Um, most terminals suppress the bell sound when that scan code is received (due
to the horrible annoying sound it makes :) ).  xterms I think eat the bell
universally (although this may be changeable in the termcap for vt100 consoles),
but they do allow you to redirect the character to a visual bell via the
shift-rightmouse menu.  Konsole has a bell configuration menu that defaults to
off, but can be set to 'system notification' to play the bell tone through the
speakers.
Comment 3 John W. Linville 2006-05-05 10:54:15 EDT
Have you tried the suggestions from comment 2?  Please do so and post the 
resuls here...thanks! 
Comment 4 Kostas Georgiou 2006-08-05 07:39:47 EDT
Isn't this because the pcspkr kernel module doesn't get loaded by default? I had
a few users complaining about this in my systems (which means that they don't
think the sound is annoying :).
Comment 5 John W. Linville 2006-10-12 11:09:52 EDT
Closed due to lack of response.  Please reopen when the requested information 
becomes availbale...thanks!

Note You need to log in before you can comment on or make changes to this bug.