Bug 1819628 - normal user get 403 Forbidden error when viewing Network In and Network Out metric on Pod Details page
Summary: normal user get 403 Forbidden error when viewing Network In and Network Out m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1821625
TreeView+ depends on / blocked
 
Reported: 2020-04-01 08:36 UTC by Yadan Pei
Modified: 2020-07-13 17:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1821625 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:24:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Normal User Get Pod Metrics Successfully (232.44 KB, image/png)
2020-04-13 05:53 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4953 0 None closed Bug 1819628: Fix bug where networking metrics unavailable to regular users 2020-06-23 09:44:23 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:25:14 UTC

Description Yadan Pei 2020-04-01 08:36:52 UTC
Description of problem:
When normal user view metrics on Pod details page, it always show 'No datapoints found' in Network In and Network Out chart while on project overview, Network Transfer(including Network In and Network Out) data is shown correctly
 
Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-03-31-203533

How reproducible:
Always

Steps to Reproduce:
1. normal user create a project and add application
$ oc new-app ruby~https://github.com/sclorg/ruby-ex.git
2. when pod is running, view pod metrics on Pod details page

Actual results:
2. Memory Usage, CPU Usage, Filesystem charts are shown correctly, it always show 'No datapoints found' in Network In and Network Out chart. Also the fetch request returns 403 
Request URL:https://<console_route>/api/prometheus/api/v1/query_range?start=1585725918.507&end=1585729518.507&step=60&query=sum%28irate%28container_network_receive_bytes_total%7Bpod%3D%27ruby-ex-1-fnngw%27%2C+namespace%3D%27yapei1-1%27%7D%5B5m%5D%29%29+by+%28pod%2C+namespace%29
Request URL:https://<console_route>/api/prometheus/api/v1/query_range?start=1585725919.918&end=1585729519.918&step=60&query=sum%28irate%28container_network_transmit_bytes_total%7Bpod%3D%27ruby-ex-1-fnngw%27%2C+namespace%3D%27yapei1-1%27%7D%5B5m%5D%29%29+by+%28pod%2C+namespace%29

Expected results:
2. Network In and Network Out data should be loaded correctly 

Additional info:

Comment 3 Yadan Pei 2020-04-13 05:53:04 UTC
Created attachment 1678375 [details]
Normal User Get Pod Metrics Successfully

Now user can get view Network In and Network Out metrics without 403 error

Verified on 4.5.0-0.nightly-2020-04-12-180647

Comment 5 errata-xmlrpc 2020-07-13 17:24:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.