Bug 181980 - pup crashes on upgrade of nautilus-open-terminal
pup crashes on upgrade of nautilus-open-terminal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 05:21 EST by William Murray
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 15:07:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Murray 2006-02-18 05:21:29 EST
Description of problem:
pup crashed on update of nautilus-open-terminal

Version-Release number of selected component (if applicable):
rpm -qa doesn't show pup. Pirut is pirut-0.9.10-1

How reproducible:
3 times in a row. Then I used yum, and all was well.

Steps to Reproduce:
1. click on pup
2. agree to upgrade 
3.
  
Actual results:
crash

Expected results:
nautlius-open-terminal upgraded

Additional info:

Component: Software Updater
Summary: TBef73f3b0 __init__.py:317:_do_update:TypeError: unsupported operand
type(s) for /: 'float' and 'NoneType'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 269, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 580, in
applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 334, in
downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 632, in downloadPkgs
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 625, in get
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 400, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 618, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 547, in _retry
    return apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 606, in
retryfunc
    fo._do_grab()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 920, in
_do_grab
    block = self.read(bs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 987, in read
    self._fill_buffer(amt)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 981, in
_fill_buffer
    self.opts.progress_obj.update(self._amount_read)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 313, in update
   urlgrabber.progress.BaseMeter.update(self, amount_read, now)
  File "/usr/lib/python2.4/site-packages/urlgrabber/progress.py", line 71, in update
    self._do_update(amount_read, now)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 317, in _do_update
    pct = float(amount_read) / self.size
TypeError: unsupported operand type(s) for /: 'float' and 'NoneType'

Local variables in innermost frame:
amount_read: 8192
self: <pirut.dlcb i
Comment 1 Rahul Sundaram 2006-02-20 06:18:38 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Jeremy Katz 2006-02-20 15:07:09 EST
It looks like this should only happen if your server isn't handing back a file
size.  Added a fix to handle this case, although it will lead to a less
responsive UI.  But not a lot we can do about that.
Comment 3 David Lawrence 2006-06-27 21:38:47 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.