This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 181986 - crash when I try to open a file with no line breaks
crash when I try to open a file with no line breaks
Status: CLOSED DUPLICATE of bug 182416
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Carl Worth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 07:38 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 06:02:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is the file with which I got the problem (62.50 KB, text/plain)
2006-02-18 07:41 EST, Juergen Bullinger
no flags Details
gedit backtrace (8.04 KB, text/plain)
2006-02-19 07:02 EST, Frank Arnold
no flags Details

  None (edit)
Description Juergen Bullinger 2006-02-18 07:38:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
Gedit crashes when I try to open a file of 64000 charactes with no line breaks.


Version-Release number of selected component (if applicable):
2.13.91

How reproducible:
Always

Steps to Reproduce:
1b. type gedit bitmask.txt in a terminal window

1b. open gedit and try to open the file from the file menu
  

Actual Results:  It hangs or even crashes with the message:

[juergen@prime test]$ gedit bitmask.txt --sync
The application 'gedit' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.



Expected Results:  I should not crash. Rather it should popup a message saying that the lines are too long.

Additional info:
Comment 1 Juergen Bullinger 2006-02-18 07:41:06 EST
Created attachment 124853 [details]
This is the file with which I got the problem
Comment 2 Frank Arnold 2006-02-19 06:51:47 EST
It turns out this is a cairo bug. It affects all GTK applications with a text
entry widget. I've got at least firefox and gnome-dictionary to crash, flooding
their input fields with about 22000 chars. GDB backtrace of a gedit crash will
be attached.
Comment 3 Frank Arnold 2006-02-19 07:02:58 EST
Created attachment 124861 [details]
gedit backtrace

Taken with:

gdb gedit
(gdb) break gdk_x_error()
(gdb) run --sync
(gdb) bt
Comment 6 Frank Arnold 2006-03-06 03:34:39 EST
Does not crash anymore. Fixing bug 182416 seemed to help.

But displaying such long lines does not work properly. Simply open the attached
file in gedit and scroll to the right. It will not display the chars any more.
Additionally, the CPU usage climbs up.
Comment 7 Carl Worth 2006-03-06 14:27:28 EST
So we root-caused the original crash down to cairo and fixed it.

The failure of gedit to then display such a long line sounds like a different
bug, and definitely is not something we've root-caused down to cairo yet.

It's generally cleaner to close a bug when it's fixed, and open a separate bug
for any related issue discovered during the investigation of the first.

But we do have bug 182416 closed already, so it might be reasonable to rename
and re-assign this bug to another component. I'll leave that decition up to "you".
Comment 8 Frank Arnold 2006-03-07 06:02:09 EST
You are right. Will file a separate bug, although it's again not specific to
gedit. So be prepared... ;)
Regarding the CPU usage, I've checked on FC4. Given the differences of the
systems (ppc32/rawhide vs. x86_64/FC4) it's comparable.

*** This bug has been marked as a duplicate of 182416 ***
Comment 9 Juergen Bullinger 2006-03-22 05:37:42 EST
gedit doesn't crash now, but as mentioned above it doesn't display the
characters after e certain position. I looks as if only the number of characters
are displayed which fit in the window. So if the window is wide enough to hold
127 chars. Gedit also displays only 127 chars. If you scroll to the right the
chars after this position are "invisible".

Note You need to log in before you can comment on or make changes to this bug.