Bug 181990 - Missing obsoletes/provides: fftw3(-devel)
Missing obsoletes/provides: fftw3(-devel)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fftw (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 08:20 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 02:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-02-18 08:20:38 EST
For sane upgradeability, compatibility, and leaving future options open, fftw
needs to have:

   Provides: fftw3 = %{version}-%{release}
   Obsoletes: fftw3 < 3.1

...and fftw-devel:

   Provides: fftw3-devel = %{version}-%{release}
   Obsoletes: fftw3-devel < 3.1

This is a blocker for fftw3* removal from the repos.
Comment 1 Ville Skyttä 2006-02-20 12:39:23 EST
I see this has been changed in the devel branch, good.  But the version number
to Obsoletes and addition of Provides is still needed in FC-4.
Comment 2 Quentin Spencer 2006-02-24 02:09:06 EST
Fixed in FC-4 now.
Comment 3 Wesley Harrell 2006-07-07 11:55:39 EDT
It looks like a better way to tag the obsoletes is:

Obsoletes: fftw3 < %{version}
and
Obsoletes: fftw3-devel < %{version}

Since the current version is 3.1.1 and the next might be 3.1.2 the 3.1 
may be incomplete or confuse the resolver, correct?

Comment 4 Quentin Spencer 2006-07-07 12:29:06 EDT
The point of obsoleting versions older than 3.1 is that there was a package name
change between 3.0 and 3.1 (from fftw3 to fftw). It is not necessary to always
obsolete the previous version; the resolver just needs to correctly upgrade both
fftw3-3.0 and fftw-3.1.1 to fftw-3.1.2 if such a release were to happen, which
it should do correctly already.
Comment 5 Wesley Harrell 2006-07-07 14:20:18 EDT
Sorry, I guess I should have been more forthcoming in my reason for posting.
I work on the Boston University Linux Project (a fedora derivative) and 
we have backported your fftw-3 to fc3, which has a fftw package, but it is 
version 2  

To make it easier for us to  stay true to fedora we need to name 
fftw v3 as fftw3.  Currently fc4 has fftw2 and fftw (v3) as you know.
For subsequent versions it would make it easier to upgrade and then 
drop modification of this package if the obsoletes actually followed 
the current version "Obsoletes: fftw3 < %{version}"

We thought we would ask the upstream maintainer if this was something 
that they could push through fedora.

Note You need to log in before you can comment on or make changes to this bug.