Bug 181995 - /etc/cron.d seems to be ignored for cronjobs
/etc/cron.d seems to be ignored for cronjobs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 11:11 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 11:47:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-02-18 11:11:02 EST
Description of problem:
/etc/cron.d seems to be ignored for cronjobs after upgrading from 4.1-42 to -52, 
because no cronjob from /etc/cron.d is executed (especially the "all 5" and "all 
15 minute" ones).

Version-Release number of selected component (if applicable):
vixie-cron-4.1-52.FC5

How reproducible:
Everytime, see above and below:

echo "*/5 * * * * uptime" > /etc/cron.d/uptime
chmod 600 /etc/cron.d/uptime
service crond reload

I never got an e-mail with the current uptime, which is the case when using -42 
rather -52.

Actual results:
Cronjobs used for vnstat package (Fedora Extras) and further one got completely 
unusable.

Expected results:
Same behaviour like in 4.1-42 again, please...
Comment 1 Jason Vas Dias 2006-02-20 11:47:02 EST
The syntax used for the cronjob line you use in an /etc/cron.d file is incorrect:
"*/5 * * * * uptime" 
A 'user name' sixth field is required in /etc/cron.d files - this line should 
work:
'
*/5 * * * * root uptime
'

4.1-42 was slightly broken in the way it read /etc/cron.d/* files (Bug 163889),
which might explain why it ran the jobs while -52+ didn't.

I've just tested that this cron job works fine in /etc/cron.d/ :
* * * * * root /bin/date
sends an email every minute OK.

Hence, this bug is being closed as 'NOTABUG'. If you still cannot get the 
uptime job to run after adding the sixth username field, please re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.