Bug 1819953 - Custom OperatorSource or any CatalogSourceConfig should create a Promethues alert
Summary: Custom OperatorSource or any CatalogSourceConfig should create a Promethues a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Anik
QA Contact: kuiwang
URL:
Whiteboard:
Depends On: 1823204
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-01 22:05 UTC by Anik
Modified: 2020-05-04 11:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1823204 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 299 None closed Bug 1819953: [release-4.4] [deprecation] Prometheus alert for custom resources 2020-04-29 11:31:46 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:48:12 UTC

Description Anik 2020-04-01 22:05:58 UTC
Description of problem:
The presence of a CatalogSourceConfig or a custom (non-default) OperatorSource does not create a Prometheus alert.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Launch OCP 4.4 cluster
2. 

oc apply -f csc.yaml

``` csc.yaml
apiVersion: "operators.coreos.com/v1"
kind: "CatalogSourceConfig"
metadata:
  name: "installed-redhat-operators"
  namespace: openshift-marketplace
spec:
  targetNamespace: openshift-marketplace
  source: redhat-operators
  packages: jaeger-product,kiali-ossm,elasticsearch-operator,servicemeshoperator
```
3. Check Monitoring -> Alerts tag in UI

Actual results:
No alerts related to presence of custom resources.

Expected results:
Alert indicating the presence of a custom resource.

Additional info:

Comment 5 errata-xmlrpc 2020-05-04 11:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.