Bug 18200 - Mouse gets "stuck" in certain situations
Summary: Mouse gets "stuck" in certain situations
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-03 09:57 UTC by fnurgel
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-03-23 09:59:56 UTC


Attachments (Terms of Use)

Description fnurgel 2000-10-03 09:57:56 UTC
If an app (for example gmc) changes the behaviour of the mousepointer
(modal mode)
and does not restore it to normal there's no way to get the mouse to return
to normal mode and to click or focus on anything.

Comment 1 Mike A. Harris 2001-03-23 05:45:03 UTC
I'm not sure what the right component for this is but I do not believe
it is XFree86.  I cannot reproduce it at all.  Could be a window manager
bug as well I think.  Actually that sounds more plausible.  What
window manager are you using?

Comment 2 fnurgel 2001-03-23 09:59:47 UTC
I wasn't sure about the component either, but I figured I had to pick something.
I was using Sawfish at the time (0.37 I believe).
I have switched back to enlightenment right now but as I recall I haven't had
this bug in this WM yet atleast.


Comment 3 Mike A. Harris 2001-03-23 10:32:31 UTC
Ok, well it seems resolved for you now then.  For the record, we have
never released that version of sawfish.  Our current is 0.36 so if
you use a newer version, you're best reporting the bug to the sawfish team.

Take care!
TTYL


Note You need to log in before you can comment on or make changes to this bug.