Bug 1820054 - metal3-io/baremetal-operator version info is not available in the log
Summary: metal3-io/baremetal-operator version info is not available in the log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Andrea Fasano
QA Contact: Shelly Miron
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-02 07:30 UTC by Sasha Smolyak
Modified: 2020-10-27 15:58 UTC (History)
3 users (show)

Fixed In Version: 4.6
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:57:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:12 UTC

Description Sasha Smolyak 2020-04-02 07:30:47 UTC
Description of problem:
metal3-io/baremetal-operator version info is not available in the log

Version-Release number of selected component (if applicable):
OPenshift: 4.4.0-0.nightly-2020-04-01-005209


How reproducible:
100%

Steps to Reproduce:
1. Deploy a cluster, observe metal3 logs:
> oc logs -n openshift-machine-api <metal3_pod> -c metal3-baremetal-operator | head
2. Watch the line in log: {"level":"info","ts":1585686677.368602,"logger":"cmd","msg":"Component version: metal3-io/baremetal-operator

Actual results:
metal3-io/baremetal-operator was not built with version info

Expected results:
The version of operator

Additional info:
virtual baremetal disconnected setup, IPv6 provisioning, IPv4 baremetal network

Comment 8 Shelly Miron 2020-08-18 12:26:43 UTC
Verified in virtual baremetal disconnected setup with IPv6 provisioning, and IPv4 baremetal network:

[kni@provisionhost-0-0 ocp-edge-auto]$ oc logs -n openshift-machine-api metal3-7d55d7859c-6flvb -c metal3-baremetal-operator | head

{"level":"info","ts":1597739233.3549712,"logger":"cmd","msg":"Go Version: go1.14.4"}
{"level":"info","ts":1597739233.3550375,"logger":"cmd","msg":"Go OS/Arch: linux/amd64"}
{"level":"info","ts":1597739233.3550477,"logger":"cmd","msg":"Version of operator-sdk: v0.17.0"}

{"level":"info","ts":1597739233.3550544,"logger":"cmd","msg":"Component version: metal3-io/baremetal-operator v4.6.0"} => ** we can see that there is now a version V4.6.0 added to the line **

{"level":"info","ts":1597739233.3555992,"logger":"cmd","msg":"gather metrics at http://127.0.0.1:8085/metrics"}
{"level":"info","ts":1597739245.6320481,"logger":"controller-runtime.metrics","msg":"metrics server is starting to listen","addr":"127.0.0.1:8085"}
{"level":"info","ts":1597739245.632382,"logger":"cmd","msg":"Registering Components."}
{"level":"info","ts":1597739245.6324503,"logger":"baremetalhost_ironic","msg":"ironic settings","endpoint":"http://[fd00:1101::3]:6385/v1/","ironicAuthType":"noauth","inspectorEndpoint":"http://[fd00:1101::3]:5050/v1/","inspectorAuthType":"noauth","deployKernelURL":"http://[fd00:1101::3]:6180/images/ironic-python-agent.kernel","deployRamdiskURL":"http://[fd00:1101::3]:6180/images/ironic-python-agent.initramfs"}
{"level":"info","ts":1597739245.6325426,"logger":"cmd","msg":"Starting the Cmd."}
{"level":"info","ts":1597739245.632729,"logger":"controller-runtime.manager","msg":"starting metrics server","path":"/metrics"}
(.venv) [kni@provisionhost-0-0 ocp-edge-auto]$

Comment 10 errata-xmlrpc 2020-10-27 15:57:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.