Bug 182007 - Keyboard selection chooses different maps for console and X
Keyboard selection chooses different maps for console and X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-18 17:56 EST by Chris Tyler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 16:04:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Tyler 2006-02-18 17:56:46 EST
Description of problem:
When the 'cf' keyboard map is selected, the correct map is chosen for text
consoles (cf) but the wrong xkb map is selected for X11 (should be "ca(fr)").

Version-Release number of selected component (if applicable):
(Anaconda present in Rawhide 2006-02-18)

Steps to Reproduce:
1. Install current Rawhide (e.g., 2006-02-18)
2. Select 'cf' keyboard
3. After installation, observe that the key in the upper-left corner of the
keyboard (to the left of the "1" key) types "#|\" (unshifted, shifted,
right-Alt) in the text consoles as expected, but types "/\|" (unshifted,
shifted, right-Alt) in X11. (Many other keys are affected as well, I mention the
upper-left key only because it's easy to reproduce/test using either the
Canadian French keyboard or the US keyboard).
  
Actual results:
Different keyboard maps are loaded for text console and X11.

Expected results:
Keyboard map will be the same.

Additional info:
System-config-keyboard does not offer the correct map either, despite the fact
that the correct map is installed on the system.

In FC <= 4 using X < 6.9, this map was known as "ca_enhanced" rather than "ca(fr)".
Comment 1 Chris Tyler 2006-02-25 10:58:01 EST
When using the text-based installer, the keyboard entry shows up as 'cf' - on
the graphical installer it is listed as 'French Canadian'.
Comment 2 David Cantrell 2006-03-01 13:49:41 EST
Is the behavior of the 'cf' map at the console correct?  For the X keymap,
here's the command that is run when you select the French Canadian map:

setxkbmap -layout ca -model pc105 -variant fr-legacy

Looking through the xkb files, this command doesn't seem correct.  I think it
should be running:

setxkbmap -layout fr_CA -model pc105 -variant fr-legacy

Is the fr_CA map the correct French Canadian map we should be loading under X.org?
Comment 3 Chris Tyler 2006-03-01 14:17:22 EST
Yes, the 'cf' map at the console is correct. It can be loaded by hand with:

  loadkeys cf

This is the keymap that is loaded if 'Canadian French' is selected using
Anaconda, so all is well on the console.

I can't get the command 'setxkbmap -layout fr_CA -model pc105 -variant
fr-legacy' to work on my (unupdated) FC5T3 system, apparently because there is
no fr_CA layout. This command does succeed but loads an incompatible map:

  setxkbmap -layout ca -model pc105 -variant fr-legacy

This is the WRONG map, as it does not match the 'cf' console map nor does it
match the keyboard which Dell, IBM, or Best Buy will sell you in Quebec.

Both of these commands do work:

  setxkbmap -layout "ca(fr)" -model pc105
  setxkbmap "ca(fr)"

Either of these will load a map which is compatible with the 'cf' map used on
the text console.

(You can test this using a US keyboard using the upper-left key on the keyboard
as noted in the original bug report).

Apparently there are new xkb maps coming in Rawhide today -- I'll test again
once the files hit my local mirror in case the map name has changed.
Comment 4 Chris Tyler 2006-03-01 15:24:30 EST
With xorg-x11-xkbdata-1.0.1-5 on my otherwise unupdated FC5T3 system, it's
necessary to add '-rules base' because setxkbmap is defaulting to '-rules xorg'.
However, the ca(fr) map is still the right one:

  setxkbmap -rules 'base' -layout 'ca(fr)' -model 'pc105'

Comment 5 David Cantrell 2006-03-01 15:48:23 EST
After looking in to it further, I found that fr_CA is incorrect.  But ca(fr)
does work.  The xorg-x11-xkbdata-1.0.1-5 problem you described with the needing
'-rules  base' will be corrected in the 1.0.1-6 build (already verified with X
team).

The keyboard loading routines are in the rhpl library, so I'm going to fix the
problem there, which should fix up system-config-keyboard since it uses rhpl as
well.

Thanks for the help with the keymap questions.

Note You need to log in before you can comment on or make changes to this bug.