Bug 1820079 - SETools 4.3.0 is available
Summary: SETools 4.3.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: setools
Version: 8.2
Hardware: All
OS: Linux
medium
unspecified
Target Milestone: rc
: 8.3
Assignee: Vit Mojzis
QA Contact: Milos Malik
lmcgarry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-02 08:34 UTC by Petr Lautrbach
Modified: 2020-11-04 02:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
.`setools` rebased to 4.3.0 The `setools` package, which is a collection of tools designed to facilitate SELinux policy analysis, has been upgraded to version 4.3.0. This update includes bug fixes and enhancements, including: * Revised `sediff` method for Type Enforcement (TE) rules, which significantly reduces memory and runtime issues. * Added `infiniband` context support to `seinfo`, `sediff`, and `apol`. * Added `apol` configuration for the location of the Qt assistant tool used to display online documentation. * Fixed `sediff` issues with: ** Properties header displaying when not requested. ** Name comparison of `type_transition` files. * Fixed permission of map socket `sendto` information flow direction. * Added methods to the `TypeAttribute` class to make it a complete Python collection. * `Genfscon` now looks up classes, rather than using fixed values which were dropped from `libsepol`. The `setools` package requires the following packages: * `setools-console` * `setools-console-analyses` * `setools-gui`
Clone Of:
Environment:
Last Closed: 2020-11-04 02:00:12 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4544 0 None None None 2020-11-04 02:00:17 UTC

Description Petr Lautrbach 2020-04-02 08:34:39 UTC
Description of problem:

https://lore.kernel.org/selinux/70175949-68b6-65da-f1a3-dc514ecf2fe1@ieee.org/T/#u


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 18 errata-xmlrpc 2020-11-04 02:00:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (setools bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4544


Note You need to log in before you can comment on or make changes to this bug.