Bug 182013 - g++ Internal Compile Error
g++ Internal Compile Error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 21:11 EST by Frank Chiulli
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 08:43:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Chiulli 2006-02-18 21:11:43 EST
Description of problem:
I received the following error attempting to build OpenOffice.
g++ -Wreturn-type -fmessage-length=0 -c -I.  -I. -I../inc
-I../../../../../../inc -I../../../../../../unx/inc
-I../../../../../../unxlngi6.pro/inc -I.
-I/home/frank/gnome/ooo-build/build/oob680-m1/solver/680/unxlngi6.pro/inc/stl
-I/home/frank/gnome/ooo-build/build/oob680-m1/solver/680/unxlngi6.pro/inc/external
-I/home/frank/gnome/ooo-build/build/oob680-m1/solver/680/unxlngi6.pro/inc
-I/home/frank/gnome/ooo-build/build/oob680-m1/solenv/unxlngi6/inc
-I/home/frank/gnome/ooo-build/build/oob680-m1/solenv/inc
-I/home/frank/gnome/ooo-build/build/oob680-m1/res
-I/home/frank/gnome/ooo-build/build/oob680-m1/solver/680/unxlngi6.pro/inc/stl
-I/home/frank/gnome/ooo-build/build/oob680-m1/solenv/inc/Xp31
-I/opt/jdk1.5.0_06/include -I/opt/jdk1.5.0_06/include/linux
-I/opt/jdk1.5.0_06/include/native_threads/include -I/usr/X11R6/include     -I.
-I../../../../../../res -I. -Os -fno-strict-aliasing -Wuninitialized   -pipe
-mtune=pentiumpro -Wno-ctor-dtor-privacy -fvisibility-inlines-hidden
-fexceptions -fno-enforce-eh-specs  -frtti  -fpic -DLINUX -DUNX -DVCL -DGCC
-DC341 -DINTEL -DCVER=C341 -D_USE_NAMESPACE -DNPTL -DGLIBC=2 -DX86 -D_PTHREADS
-D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400
-DHAVE_GCC_VISIBILITY_FEATURE -D__DMAKE -DUNIX -DCPPU_ENV=gcc3
-DGXX_INCLUDE_PATH=/usr/lib/gcc/i386-redhat-linux/4.0.2/../../../../include/c++/4.0.2
-DSUPD=680 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE
-DEXCEPTIONS_ON -DCUI -DSOLAR_JAVA -DOOB680=OOB680   -DSHAREDLIB -D_DLL_ 
-DMULTITHREAD  -o ../../../../../../unxlngi6.pro/slo/WP3Listener.o
/home/frank/gnome/ooo-build/build/oob680-m1/libwpd/unxlngi6.pro/misc/build/libwpd-0.8.4/src/lib/WP3Listener.cpp
*** glibc detected *** /usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus:
malloc(): memory corruption: 0x09d54980 ***
======= Backtrace: =========
/lib/libc.so.6[0xb5e0ea]
/lib/libc.so.6(malloc+0x74)[0xb5f492]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x8422e02]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x835f7ae]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x81a6277]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x81a6713]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x8222619]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x82237b0]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x8365e2b]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x8366a55]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x810e832]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x810eab7]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x80bf989]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x838bc33]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x838c9ed]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x808cb35]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x80f7285]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus[0x834dbb9]
/lib/libc.so.6(__libc_start_main+0xdf)[0xb0ed5f]
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus(calloc+0x179)[0x8049b01]
======= Memory map: ========
0047a000-00483000 r-xp 00000000 03:02 2600058    /lib/libgcc_s-4.0.2-20051126.so.1
00483000-00484000 rwxp 00009000 03:02 2600058    /lib/libgcc_s-4.0.2-20051126.so.1
00adc000-00af6000 r-xp 00000000 03:02 2599987    /lib/ld-2.3.5.so
00af6000-00af7000 r-xp 00019000 03:02 2599987    /lib/ld-2.3.5.so
00af7000-00af8000 rwxp 0001a000 03:02 2599987    /lib/ld-2.3.5.so
00afa000-00c1d000 r-xp 00000000 03:02 2600025    /lib/libc-2.3.5.so
00c1d000-00c1f000 r-xp 00123000 03:02 2600025    /lib/libc-2.3.5.so
00c1f000-00c21000 rwxp 00125000 03:02 2600025    /lib/libc-2.3.5.so
00c21000-00c23000 rwxp 00c21000 00:00 0
00dab000-00dac000 r-xp 00dab000 00:00 0          [vdso]
08047000-0851b000 r-xp 00000000 03:02 310723    
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus
0851b000-0851e000 rw-p 004d4000 03:02 310723    
/usr/libexec/gcc/i386-redhat-linux/4.0.2/cc1plus
0851e000-0859c000 rw-p 0851e000 00:00 0
09cb2000-09d75000 rw-p 09cb2000 00:00 0          [heap]
b6e00000-b6e21000 rw-p b6e00000 00:00 0
b6e21000-b6f00000 ---p b6e21000 00:00 0
b6f53000-b7f66000 rw-p b6f53000 00:00 0
b7f6a000-b7f77000 rw-p b7f6a000 00:00 0
bfe5e000-bfe77000 rw-p bfe5e000 00:00 0          [stack]
/home/frank/gnome/ooo-build/build/oob680-m1/solver/680/unxlngi6.pro/inc/stl/stl/_uninitialized.h:
In function '_ForwardIter _STL::__uninitialized_copy(_InputIter, _InputIter,
_ForwardIter, const _STL::__false_type&) [with _InputIter = const
_WPXColumnDefinition*, _ForwardIter = _WPXColumnDefinition*]':
/home/frank/gnome/ooo-build/build/oob680-m1/solver/680/unxlngi6.pro/inc/stl/stl/_uninitialized.h:70:
internal compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
dmake:  Error code 1, while making
'../../../../../../unxlngi6.pro/slo/WP3Listener.obj'
'---* tg_merge.mk *---'
dmake:  Error code 255, while making './unxlngi6.pro/misc/build/so_built_wpd'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making
/home/frank/gnome/ooo-build/build/oob680-m1/libwpd
make: *** [stamp/build] Error 1


Version-Release number of selected component (if applicable):
 g++ -v
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--enable-checking=release --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-libgcj-multifile
--enable-languages=c,c++,objc,java,f95,ada --enable-java-awt=gtk
--with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --host=i386-redhat-linux
Thread model: posix
gcc version 4.0.2 20051125 (Red Hat 4.0.2-8)


How reproducible:
Check out OpenOffice from CVS.  Do an autogen.sh, download, make.

Steps to Reproduce:
1. cvs -z3 checkout ooo-build
2. cd ooo-build
3. ./autogen.sh --disable-kde --with-distro=SUSE9.3
4. ./download
5. make
  
Actual results:
Compiler aborts.

Expected results:
OpenOffice compiles and builds successfully.

Additional info:
Comment 1 Jakub Jelinek 2006-02-20 04:23:46 EST
Please provide preprocessed testcase if the above is reproduceable, i.e.
add -save-temps to the above command line and attach here the *.ii file
it creates.
Comment 2 Frank Chiulli 2006-02-21 00:04:42 EST
I was unable to reproduce this problem by copying the compile statement to a
file and executing it.

I re-executed the make.  It had failed twice before in the same spot.  This time
it went past where it has failed before.  But it still failed on a g++ statement
with the same type error (malloc).  I tried copying this compile statement to a
file and executing it.  It also worked.

Is this a hardware problem?  The first time this occurred I booted by Fedora
Rescue CD and ran memtest for 8.5 hours.  There were no reported errors.
Comment 3 Jakub Jelinek 2006-02-21 01:59:39 EST
You can try running make from within
setarch -R /bin/sh
to turn off randomization.  If you can't reproduce the problem on the exact same
file exact same error, then it is a hardware problem.
Comment 4 Frank Chiulli 2006-02-27 08:42:25 EST
I tried but was unable to reproduce the problem on the exact same file with the
exact same error.  Therefore I am assuming it is a hardware problem.  I thank
you for your time and effort.

Note You need to log in before you can comment on or make changes to this bug.