Bug 1820131 - openblas 3.9.0 bug with C++
Summary: openblas 3.9.0 bug with C++
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openblas
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1811026
TreeView+ depends on / blocked
 
Reported: 2020-04-02 10:34 UTC by Théodore Papadopoulo
Modified: 2020-04-11 22:21 UTC (History)
1 user (show)

Fixed In Version: openblas-0.3.9-2.fc32 openblas-0.3.9-2.fc30 openblas-0.3.9-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-02 12:03:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Théodore Papadopoulo 2020-04-02 10:34:35 UTC
Description of problem:
Version openblas 3.9.0 has a bug when used with C++


Version-Release number of selected component (if applicable): 0.3.9-1 (and probably 0.3.9-0 too)


How reproducible:
Deterministic

Steps to Reproduce:
1. Create file test.cpp containing just "#include <openblas/lapack.h>"
2. g++ test.cpp

Actual results:
In file included from /usr/include/c++/9/bits/stringfwd.h:40,
                 from /usr/include/c++/9/iosfwd:39,
                 from /usr/include/c++/9/ios:38,
                 from /usr/include/c++/9/istream:38,
                 from /usr/include/c++/9/sstream:38,
                 from /usr/include/c++/9/complex:45,
                 from /usr/include/openblas/lapack.h:58,
                 from test.C:1:
/usr/include/c++/9/bits/memoryfwd.h:63:3: error: template with C linkage
   63 |   template<typename>
      |   ^~~~~~~~
In file included from test.C:1:
/usr/include/openblas/lapack.h:16:1: note: ‘extern "C"’ linkage started here
   16 | extern "C" {
      | ^~~~~~~~~~
In file included from /usr/include/c++/9/bits/stringfwd.h:40,
[Ignoring 21870 other lines of the same style]

Expected results:
No error


Additional info:
The bug has been corrected upstream with commit 51019feae1f65a22075c4d28efcabdbb35cd2c6f (openblas).

Comment 1 Théodore Papadopoulo 2020-04-02 10:35:59 UTC
Will solve bug 1811026

Comment 2 Susi Lehtola 2020-04-02 12:03:47 UTC
Thanks, fixed packages building.

PS. Next time please put the upstream fix at the beginning of the report, since including the upstream patch is much faster than reproducing the problem, figuring out why it occurs, and seeing if upstream is aware of it...

Comment 3 Fedora Update System 2020-04-03 07:47:07 UTC
FEDORA-2020-63a0928be3 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-63a0928be3

Comment 4 Fedora Update System 2020-04-03 07:47:08 UTC
FEDORA-2020-3e774fe65a has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3e774fe65a

Comment 5 Fedora Update System 2020-04-03 07:47:10 UTC
FEDORA-2020-bef0859d29 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-bef0859d29

Comment 6 Fedora Update System 2020-04-04 02:41:08 UTC
FEDORA-2020-bef0859d29 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-bef0859d29`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bef0859d29

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-04-04 03:57:53 UTC
FEDORA-2020-63a0928be3 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-63a0928be3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-63a0928be3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-04-04 06:16:54 UTC
FEDORA-2020-3e774fe65a has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-3e774fe65a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3e774fe65a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-04-09 14:44:11 UTC
FEDORA-2020-3e774fe65a has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-04-11 21:51:20 UTC
FEDORA-2020-63a0928be3 has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-04-11 22:21:31 UTC
FEDORA-2020-bef0859d29 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.