Bug 1820307 - YAML edit has "View sidebar" at some screen widths too small for the sidebar
Summary: YAML edit has "View sidebar" at some screen widths too small for the sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-02 17:57 UTC by Samuel Padgett
Modified: 2020-07-13 17:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-04-02-090658 Cluster ID: ebff9da8-95a2-47f6-9d34-0966ac39002b Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:74.0) Gecko/20100101 Firefox/74.0
Last Closed: 2020-07-13 17:25:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4926 0 None closed Bug 1820307: Hide yaml editor links when window width is less than 991px 2020-06-23 09:47:35 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:25:41 UTC

Description Samuel Padgett 2020-04-02 17:57:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Samuel Padgett 2020-04-02 18:00:08 UTC
The YAML edit shows a "View sidebar" link at some window widths where the sidebar isn't displayed (about ~950 pixels wide). Click the link causes the link to disappear, but the sidebar isn't shown until you widen the window.

We should just hide the link at these screen widths.

Comment 4 Yadan Pei 2020-04-08 10:12:07 UTC
1. Goto YAML editor page of any resource, scale down browser window size to 991(width) x  Any height value, 'View Shortcuts' and 'View sidebar' will be hidden. When we resize browser window to larger size, 'View Shortcuts' and 'View sidebar' appear 

I use browsersize.com to check my current browser window size


Verified on 4.5.0-0.nightly-2020-04-07-201442

Comment 6 errata-xmlrpc 2020-07-13 17:25:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.