Bug 182034 - Spam Tag not working ($sa_tag_level_deflt)
Spam Tag not working ($sa_tag_level_deflt)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amavisd-new (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 11:40 EST by Axel Suppantschitsch
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-25 04:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Suppantschitsch 2006-02-19 11:40:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
Spam Tagging at the lowest configured level ($sa_tag_level_deflt = 2.0;) does not work though it is activated in the conf file:

$sa_tag_level_deflt  = 2.0;  # add spam info headers if at, or above
that level
$sa_tag2_level_deflt = 6.31; # add 'spam detected' headers at that
level
$sa_kill_level_deflt = 6.31; # triggers spam evasive actions
$sa_dsn_cutoff_level = 9;    # spam level beyond which a DSN is not
sent 

Version-Release number of selected component (if applicable):
amavisd-new-2.3.3-5.fc4

How reproducible:
Always

Steps to Reproduce:
1. Mail is received from amavisd-new through postfix
2. Mail gets spam checked (Spamasssassin) and gets a rating e.g.: 3.431 hits

  

Actual Results:  No spam info headers are added to the email header at and above 2.0 hits although they should be added due to the active configuration of: $sa_tag_level_deflt = 2.0;

Expected Results:  Spam info headers should be added to the email header, e.g.: X-Spam-Level: ***

Additional info:
Comment 1 Steven Pritchard 2006-03-20 13:49:55 EST
Have you reported this upstream by any chance?  There shouldn't be anything
special in the Fedora package that would break that.  (And I have noticed this
before, so I believe you that it is broken.)
Comment 2 Axel Suppantschitsch 2006-03-23 03:33:18 EST
(In reply to comment #1)
> Have you reported this upstream by any chance?  There shouldn't be anything
> special in the Fedora package that would break that.  (And I have noticed this
> before, so I believe you that it is broken.)

Hi Steve,

no, I didn't report this to the author of amavisd-new yet. But I'll send this 
bugreport over to him, he's a very cooperative guy... I get back to you as soon 
as I have an answer.

Cheers, Axel.

Comment 3 Axel Suppantschitsch 2006-03-23 03:33:50 EST
(In reply to comment #1)
> Have you reported this upstream by any chance?  There shouldn't be anything
> special in the Fedora package that would break that.  (And I have noticed this
> before, so I believe you that it is broken.)

Hi Steve,

no, I didn't report this to the author of amavisd-new yet. But I'll send this 
bugreport over to him, he's a very cooperative guy... I get back to you as soon 
as I have an answer.

Cheers, Axel.

Comment 4 Axel Suppantschitsch 2006-03-25 04:06:30 EST
Problem is not a bug, but a configuration issue:

The recipeients need to be considered local, as any tagging is done for local
recipients only.

$mydomain = 'example.com';   # a convenient default for other settings
@local_domains_maps = ( [".$mydomain"] );

It is crucial that $mydomain contains the local recipeint domain. If there is no
match, no spam tag is added.

Cheers, Axel.


Note You need to log in before you can comment on or make changes to this bug.