Bug 1820474 - Missing openapi CRD definitions for oc explain to work for cluster autoscaler operator
Summary: Missing openapi CRD definitions for oc explain to work for cluster autoscaler...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Alberto
QA Contact: sunzhaohua
URL:
Whiteboard:
: 1823693 (view as bug list)
Depends On: 1769004 1816624 1823692
Blocks: 1823693 1823715 1823717
TreeView+ depends on / blocked
 
Reported: 2020-04-03 07:32 UTC by Alberto
Modified: 2020-08-27 22:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1769004
: 1823693 1823715 (view as bug list)
Environment:
Last Closed: 2020-08-27 22:35:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-autoscaler-operator pull 146 0 None closed Bug 1820474: clusterAutoscaler and machineAutoscaler structural schema 2020-09-16 06:31:10 UTC

Description Alberto 2020-04-03 07:32:30 UTC
+++ This bug was initially created as a clone of Bug #1769004 +++

The following PR https://github.com/openshift/origin/pull/22696 introduced an e2e which is verifying that all the operators provide descriptive information as part of their schema which is then available through oc explain command. 
This was recently updated and brought back in https://github.com/openshift/origin/pull/24058. 

Your component has a few missing bits, see the commented out lines from the PR.

This should be fixed similarly to https://github.com/openshift/cluster-kube-controller-manager-operator/pull/302, 
iow. it should be using openshift/api's generated CRD yamls. 

Once done update origin's e2e test and uncomment the lines from your components.

--- Additional comment from Alberto on 2020-01-23 10:07:36 UTC ---



--- Additional comment from Alberto on 2020-03-04 15:13:55 UTC ---



--- Additional comment from Alberto on 2020-04-01 15:21:58 UTC ---

Lowering severity as MHC is covered by https://bugzilla.redhat.com/show_bug.cgi?id=1816624. We'll create specific tickets for clusterAutoscaler and machineAutoscaler resources. Machine will need more work due to the embedded providerSpec as a raw extension.

Comment 3 sunzhaohua 2020-04-09 10:00:05 UTC
verified

clusterversion: 4.5.0-0.nightly-2020-04-08-113336
$ oc explain clusterautoscaler
KIND:     ClusterAutoscaler
VERSION:  autoscaling.openshift.io/v1

DESCRIPTION:
     ClusterAutoscaler is the Schema for the clusterautoscalers API

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object>
     Desired state of ClusterAutoscaler resource

   status	<map[string]>
     Most recently observed status of ClusterAutoscaler resource

$ oc explain machineautoscaler
KIND:     MachineAutoscaler
VERSION:  autoscaling.openshift.io/v1beta1

DESCRIPTION:
     MachineAutoscaler is the Schema for the machineautoscalers API

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object>
     Specification of constraints of a scalable resource

   status	<Object>
     Most recently observed status of a scalable resource

Comment 4 Alberto 2020-04-14 10:16:52 UTC
*** Bug 1823693 has been marked as a duplicate of this bug. ***

Comment 5 Luke Meyer 2020-08-27 22:35:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409'


Note You need to log in before you can comment on or make changes to this bug.