Bug 1820613 - csr-signer isn't refreshed in recovery flow
Summary: csr-signer isn't refreshed in recovery flow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1820610
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-03 13:03 UTC by Tomáš Nožička
Modified: 2020-05-04 11:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1820610
Environment:
Last Closed: 2020-05-04 11:48:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 386 0 None closed [release-4.4] Bug 1820613: Refresh csr-signer in recovery flow 2020-05-05 12:20:10 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:48:21 UTC

Description Tomáš Nožička 2020-04-03 13:03:07 UTC
+++ This bug was initially created as a clone of Bug #1820610 +++

Description of problem:
KCM recovery side car isn't refreshing csr-signer and csr-signer-signer


Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-04-01-141451

How reproducible:
always


Steps to Reproduce:
1. stop cluster for 25h
2.
3.

Actual results:
    auth.openshift.io/certificate-issuer: kubelet-signer
    auth.openshift.io/certificate-not-after: "2020-04-02T18:34:29Z"
    auth.openshift.io/certificate-not-before: "2020-04-01T18:48:01Z"


Expected results:
    auth.openshift.io/certificate-issuer: openshift-kube-controller-manager-operator_csr-signer-signer@1585915545

Additional info:

Comment 1 Tomáš Nožička 2020-04-03 13:08:10 UTC
QA note: this is purely related to auto recovery flow, not the manual steps

Comment 4 zhou ying 2020-04-15 13:23:04 UTC
Checked with payload 4.4.0-0.nightly-2020-04-13-113747 , the issue has fixed:

[root@dhcp-140-138 ~]# oc get secrets csr-signer -o json -n openshift-kube-controller-manager-operator
{
    "apiVersion": "v1",
    "data": {
...
    "kind": "Secret",
    "metadata": {
        "annotations": {
            "auth.openshift.io/certificate-issuer": "openshift-kube-controller-manager-operator_csr-signer-signer@1586956289",
            "auth.openshift.io/certificate-not-after": "2020-05-15T13:11:29Z",
            "auth.openshift.io/certificate-not-before": "2020-04-15T13:11:28Z"

Comment 6 errata-xmlrpc 2020-05-04 11:48:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.