Bug 182076 - Elantech touchpad occasionally moves and clicks randomly
Elantech touchpad occasionally moves and clicks randomly
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-02-20 03:21 EST by Jaak Simm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.16-1.2080_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-30 06:58:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jaak Simm 2006-02-20 03:21:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
Moving the mouse cursor around with touchpad triggers occasionally erratic behavior, resulting in quick random movement and random clicks. It happens once in 2-3 minutes and lasts few seconds. When the erratic behavior stops, the /var/log/messages always reports the following message:

Feb 20 09:10:45 localhost kernel: psmouse.c: Wheel Mouse at isa0060/serio4/input0 lost synchronization, throwing 3 bytes away.

(The number of bytes thrown away is reported to be 2 or 3 usually.)

The bug does not happen with an external usb mouse.
The bug does not happen if I do not move the touchpad mouse (erratic behavior appears only when actively moving the mouse cursor with touchpad).
The bug does not happen, if I turn off ACPI at boot by specifying acpi=off at the kernel boot line. Unfortunately, it is not a valid workaround, because it forces the laptop's fans to full throttle.

The brand of the laptop is EFL30 with Pentium M. It has Elantech touchpad version 5, which does not support synaptics driver, but is recognized as some Logitech mouse in FC4.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. make sure acpi is on
2. move mouse cursor using the laptop's touchpad for a minute or two

Actual Results:  Erratic behavior of the mouse cursor and random clicking occurs.
Also a line mentioned above is written into the /var/log/messages

Expected Results:  normal mouse behavior

Additional info:

I tried also earlier kernels, same behavior.
The bug is not fedora specific, other distros have the same problem with the touchpad (like suse, ubuntu). When searching the net, it seemed also others were having the same problem with Elantech touchpad under linux.

Kernel finds actually two mice (without any external mice connected), 
# cat /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0005 Version=0063
N: Name="ImPS/2 Logitech Wheel Mouse"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input1
H: Handlers=mouse0 event1
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input2
H: Handlers=mouse1 event2
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

It seems that the second one is not working, only the first of them (isa0060/serio4/input0) works and also generates the erratic behavior.

# dmesg | grep mouse
mice: PS/2 mouse device common for all mice
logips2pp: Detected unknown logitech mouse model 99
psmouse.c: Failed to enable mouse on isa0060/serio1
psmouse.c: Wheel Mouse at isa0060/serio4/input0 lost synchronization, throwing 3 bytes away.

### /etc/X11/xorg.conf ###
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"

Also tried different options in xorg.conf, but they didnt result in any change in the behavior.
Comment 1 Jaak Simm 2006-02-20 12:50:27 EST
A small update on other distros.
The newest alpha live cd of Ubuntu (6.04, flight 4) does not have the bug with
the touchpad. However, the previous release of Ubuntu (5.10) had the same
problems as FC4.

Note You need to log in before you can comment on or make changes to this bug.