This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 182078 - How to specify file system label for anaconda in ks.cfg
How to specify file system label for anaconda in ks.cfg
Status: CLOSED DUPLICATE of bug 79832
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 03:37 EST by Robinson Tiemuqinke
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 15:50:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robinson Tiemuqinke 2006-02-20 03:37:08 EST
Description of problem:

I don't know if there is a way to specify file system labels for ext3 file 
systems and swap areas in ks.cfg. It looks like that the file system labels 
are related to the file system's mounting points if not explicitly specified, 
but only a wide guess. 

Let's give an example here, in ks.cfg I have the following configuration:
...
part / --fstype ext3 --onpart sda1
part /usr --fstype ext3 --onpart sda5
part swap --onpart sda6
part swap --onpart sda7
part swap --onpart sda8
part /example --fstype ext3 --onpart sda9
part /var --fstype ext3 --onpart sda10
part /0 --fstype ext3 --onpart sda11
...

Then after the machine is installed and rebooted, from /etc/fstab we can find 
that the / file system's label is /1, /0 file system's label is /01, some time 
the /{usr,var,example}'s label are also appeneded with '1', other times they 
are not. pretty strange.

Even worse are the swap areas, their label is so completely full of unreadable 
characters that the system booting complains. it is supposed to be labled as 
something like 'SWAP-sda{6,7,8}' but in fact they are not.

Version-Release number of selected component (if applicable):

default installation media for FC4

How reproducible:

Every kickstart.

Steps to Reproduce:
1. create partitions with fdisk in a interactive shell screen during an 
interactive installation, sync the hard disk, and abort installation. We do 
this because the default graphic disk-partition screen is not as accurate or 
davanced as fdisk, and we need to make a consistent system disk partition 
schema for years. 

2. reboot the machine and this time run automatic kickstart installation, with
the partitions definition listed above.

3. System will installed and rebooted, Have a look of /etc/fstab after machine 
reboots. The problems are shown there.
  
Actual results:

talked about already.

Expected results:

every ext3/ext2 file system's label(volumn) should have the exact same name as 
its mouning point, "/" for "/", "/usr" for "/usr", "/0" for "/0". no extra or 
less characters should be added or deleted.

SWAP areas should have their names follow a name format like "SWAP-
<partitionName>", or "SWAP{1,2,3..10}".

Additional info:
Comment 1 Jeremy Katz 2006-02-20 15:50:26 EST

*** This bug has been marked as a duplicate of 79832 ***

Note You need to log in before you can comment on or make changes to this bug.