Bug 1820988 - Fail to add "IPv6 only" host without fqdn to Engine
Summary: Fail to add "IPv6 only" host without fqdn to Engine
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: ovirt-host-deploy-ansible
Version: 4.4.0
Hardware: All
OS: Linux
high
high
Target Milestone: ovirt-4.4.1
: ---
Assignee: Dana
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1791555 1680970 1807256
TreeView+ depends on / blocked
 
Reported: 2020-04-05 08:42 UTC by Roni
Modified: 2020-07-08 08:24 UTC (History)
8 users (show)

Fixed In Version: ansible-runner-service-1.0.2
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-08 08:24:55 UTC
oVirt Team: Infra
pm-rhel: ovirt-4.4+
aoconnor: blocker+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ansible ansible-runner-service issues 49 None closed add ipv6 support to ansible hosts 2021-01-22 08:40:24 UTC
Github ansible ansible-runner-service pull 51 None closed Handle connection to IPv6 hosts 2021-01-22 08:40:25 UTC

Description Roni 2020-04-05 08:42:00 UTC
Description of problem:
Fail to add IPv6 only host to Engine by its IPv6 address

Version-Release number of selected component (if applicable):
v4.4.0-0.29
rhvh-4.4.0.16-0.20200401

How reproducible:
100%

Steps to Reproduce:
1. Reprovision RHVH host (rhvh-4.4.0.16-0.20200401)
2. On the host, modify the management connection (using nmcli)
   - disable IPv4 
   - set static IPv6
   - set default-gateway
   - set DNS by its IPv6 address
3. Add the host to Engine
   At the "Hostname/IP" field enter the host IPv6 address (not its FQDN)

Actual results:
Add host fail

Expected results:
The host should be added successfully

Additional info:
The same issue occurs when deploying hosted-engine on IPv6 host only
See attached logs for both adding IPv6 host and also deploy HE on IPv6 host

Comment 16 RHEL Program Management 2020-04-06 06:45:39 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 17 Dominik Holler 2020-04-06 08:35:33 UTC
[user@centos-8-gui scripts]$ curl -v -X POST "http://127.0.0.1:50001/api/v1/hosts/2001:16b8:177b:5700:aafd:cc51:902e:6572/groups/ovirt?port=22"
*   Trying 127.0.0.1...
* TCP_NODELAY set
* Connected to 127.0.0.1 (127.0.0.1) port 50001 (#0)
> POST /api/v1/hosts/2001:16b8:177b:5700:aafd:cc51:902e:6572/groups/ovirt?port=22 HTTP/1.1
> Host: 127.0.0.1:50001
> User-Agent: curl/7.61.1
> Accept: */*
> 
< HTTP/1.1 404 NOT FOUND
< Server: gunicorn/20.0.4
< Date: Mon, 06 Apr 2020 08:34:23 GMT
< Connection: close
< Content-Type: application/json
< Content-Length: 185
< 
{"status": "NOCONN", "msg": "SSH error - '2001:16b8:177b:5700:aafd:cc51:902e:6572' not found; check DNS or /etc/hosts", "data": {"hostname": "2001:16b8:177b:5700:aafd:cc51:902e:6572"}}
* Closing connection 0

Comment 18 Dominik Holler 2020-04-06 08:37:03 UTC
Roni, is this known to work ever on ovirt-4.4?

Comment 23 Dana 2020-04-07 20:32:53 UTC
posted a fix to ansible-runner-service:
https://github.com/ansible/ansible-runner-service/pull/51/files

Comment 24 Michael Burman 2020-05-12 07:54:10 UTC
I believe this can be moved to ON_QA now as ansible-runner-service-1.0.2-1.el8ev available in rhv-release-4.4.0-35-001.noarch

Comment 25 Martin Perina 2020-05-12 08:43:08 UTC
(In reply to Michael Burman from comment #24)
> I believe this can be moved to ON_QA now as
> ansible-runner-service-1.0.2-1.el8ev available in
> rhv-release-4.4.0-35-001.noarch

Yes, moving

Comment 26 Michael Burman 2020-05-17 13:46:08 UTC
Verified on - ansible-runner-service-1.0.2-1.el8ev.noarch with
rhvh-4.4.0.18-0.20200507.0+1
vdsm-4.40.14-1.el8ev.x86_64
nmstate-0.2.6-6.el8.noarch
rhvm-4.4.0.2-0.1.el8ev.noarch

Pls note that this is verifying only the stand alone flow of adding a host to RHV over a static only IPv6 address.
The HE flow is failing and failed. We suspect for a new regression bug, becasue HE has failed over a new error:

"You must specify either 'url' or 'hostname'" 
which is related to ovirt_auth ansible module
Currently the HE over a static IPv6 still failing. We are investigating and report new bug for the HE over IPv6 static address flow.
This error is something new.

Comment 27 Michael Burman 2020-05-18 07:54:56 UTC
HE ipv6 flow is tracked in BZ 1836638

Comment 28 Sandro Bonazzola 2020-07-08 08:24:55 UTC
This bugzilla is included in oVirt 4.4.1 release, published on July 8th 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.