Bug 1821077 - gcc 9.3.1 internal compiler error: in get_fns, at cp/tree.c:2455
Summary: gcc 9.3.1 internal compiler error: in get_fns, at cp/tree.c:2455
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-05 21:57 UTC by Mattias Ellert
Modified: 2020-10-05 08:28 UTC (History)
10 users (show)

Fixed In Version: gcc-9.3.1-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-16 22:41:12 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 93597 P1 REOPENED [9 Regression] ICE in get_fns since r10-6219 2020-04-05 22:29:27 UTC

Description Mattias Ellert 2020-04-05 21:57:29 UTC
Description of problem:

After the update to gcc 9.3.1 in Fedora 31, the HepMC3 package started fail to build due to an internal compiler error:

https://koschei.fedoraproject.org/package/HepMC3?collection=f31

I have reproduced the failure reported by Koschei using a local mock build.

Version-Release number of selected component (if applicable):

gcc-c++-9.3.1-1.fc31

How reproducible:

Found by Koschei, reproducible in local mock.

Steps to Reproduce:
1. Rebuild HepMC3-3.2.1-1 in Fedora 31 using gcc 9.3.1-1

Actual results:

ICE - failed build

Expected results:

Successful build

Additional info:

This is a regression. The package could be built using gcc 9.2.1-1.fc31

Comment 1 Mattias Ellert 2020-04-05 22:24:53 UTC
The same error happens using gcc-c++-9.3.1-1.fc30 in a Fedora 30 mock build - this was not tested by Koschei yet,

Comment 2 Marek Polacek 2020-04-06 00:42:02 UTC
Fixed upstream on the 9 branch.

Comment 3 Fedora Update System 2020-04-09 10:41:29 UTC
FEDORA-2020-4a00b42dc9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4a00b42dc9

Comment 4 Fedora Update System 2020-04-09 19:14:06 UTC
FEDORA-2020-4a00b42dc9 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4a00b42dc9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4a00b42dc9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-04-16 22:41:12 UTC
FEDORA-2020-4a00b42dc9 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.