This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 182115 - SQLite not configure with --enable-threadsafe
SQLite not configure with --enable-threadsafe
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sqlite3 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 12:13 EST by Derek Atkins
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 14:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek Atkins 2006-02-20 12:13:23 EST
Description of problem:
I've had trac fail and lock the database, require restarting httpd.  According
to http://projects.edgewall.com/trac/ticket/1661 part of the problem is that
sqlite is not compiled with --enable-threadsafe.  I verified that the FC4 spec
file does indeed fail to configure --enable-threadsafe.

Version-Release number of selected component (if applicable):
[root@cvs ~]# rpm -q sqlite
sqlite-3.1.2-3

How reproducible:
The trac bug I've only seen once, but the lack of threadsafe-mode is 100%
reproducible.

Steps to Reproduce:
1. rpmbuild --rebuild sqlite-3.1.2-3.src.rpm
2. notice that it still doesn't configure with --enable-threadsafe
3. file a bug report to get this fixed.
  
Actual results:
trac database lock due to multithreaded access to sqlite through mod_python

Expected results:
threadsafe access to a sqlite database.

Additional info:
Comment 1 Paul Nasrat 2006-08-14 14:38:42 EDT
Fixed from 3.3.6-1

Note You need to log in before you can comment on or make changes to this bug.