Bug 1821183 - qcad hangs and eventually crashes
Summary: qcad hangs and eventually crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qcad
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. sagitter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-06 09:11 UTC by Pontus Enhager
Modified: 2020-09-25 16:41 UTC (History)
2 users (show)

Fixed In Version: 3.24.3.0 qcad-3.25.1.0-1.fc32 qcad-3.25.1.0-1.fc31 qcad-3.25.1.0-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-05 18:32:15 UTC
Type: Bug


Attachments (Terms of Use)
an strace log (13.02 KB, text/plain)
2020-04-06 09:16 UTC, Pontus Enhager
no flags Details
a qcad.spec patch for 3.24.3.0 (248 bytes, patch)
2020-04-06 14:20 UTC, Pontus Enhager
no flags Details | Diff
updated patch (old one vs wrong version) (657 bytes, patch)
2020-04-06 14:43 UTC, Pontus Enhager
no flags Details | Diff

Description Pontus Enhager 2020-04-06 09:11:24 UTC
Description of problem:
Trying to copy a section of a small drawing in QCAD by means of the move tool stops the  qcad process and eventually crashes it


 [pontus@palsternacka ~]$ valgrind qcad 
==6985== Memcheck, a memory error detector
==6985== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==6985== Using Valgrind-3.15.0 and LibVEX; rerun with -h for copyright info
==6985== Command: /usr/bin/qcad
==6985== 
Warning:  RPropertyTypeId::generateId: property already initialized:  7RObject : "" : "Invisible"
/usr/bin/qcad: line 3:  6986 Segmentation fault      (core dumped) /usr/lib64/qcad/qcad-bin "$@"
==6985== 
==6985== HEAP SUMMARY:
==6985==     in use at exit: 163,110 bytes in 2,050 blocks
==6985==   total heap usage: 4,018 allocs, 1,968 frees, 246,434 bytes allocated
==6985== 
==6985== LEAK SUMMARY:
==6985==    definitely lost: 0 bytes in 0 blocks
==6985==    indirectly lost: 0 bytes in 0 blocks
==6985==      possibly lost: 0 bytes in 0 blocks
==6985==    still reachable: 163,110 bytes in 2,050 blocks
==6985==         suppressed: 0 bytes in 0 blocks
==6985== Rerun with --leak-check=full to see details of leaked memory
==6985== 
==6985== For lists of detected and suppressed errors, rerun with: -s
==6985== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)

--------------

[pontus@palsternacka ~]$ valgrind qcad --leak-check=full -s
==7489== Memcheck, a memory error detector
==7489== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==7489== Using Valgrind-3.15.0 and LibVEX; rerun with -h for copyright info
==7489== Command: /usr/bin/qcad --leak-check=full -s
==7489== 
Warning:  RPropertyTypeId::generateId: property already initialized:  7RObject : "" : "Invisible"
/usr/bin/qcad: line 3:  7490 Segmentation fault      (core dumped) /usr/lib64/qcad/qcad-bin "$@"
==7489== 
==7489== HEAP SUMMARY:
==7489==     in use at exit: 163,149 bytes in 2,054 blocks
==7489==   total heap usage: 4,035 allocs, 1,981 frees, 246,511 bytes allocated
==7489== 
==7489== LEAK SUMMARY:
==7489==    definitely lost: 0 bytes in 0 blocks
==7489==    indirectly lost: 0 bytes in 0 blocks
==7489==      possibly lost: 0 bytes in 0 blocks
==7489==    still reachable: 163,149 bytes in 2,054 blocks
==7489==         suppressed: 0 bytes in 0 blocks
==7489== Rerun with --leak-check=full to see details of leaked memory
==7489== 
==7489== For lists of detected and suppressed errors, rerun with: -s
==7489== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)


Version-Release number of selected component (if applicable):
qcad-3.24.2.6-2.fc31.x86_64


How reproducible:
very often

Steps to Reproduce:
1.draw something
2.write something
3.rotate it all
4.move it all

Actual results:
crash

Expected results:


Additional info:
above recipe might be able to simplify
i did use swedish syllables in the text (åäö)

Comment 1 Pontus Enhager 2020-04-06 09:16:34 UTC
Created attachment 1676522 [details]
an strace log

Comment 2 Antonio T. (sagitter) 2020-04-06 09:33:37 UTC
I'm sorry, i can't reproduce any crash with this release.

Comment 3 Pontus Enhager 2020-04-06 12:01:47 UTC
text is not the crucial part here whatever command is made after a rotate of something hangs and later on crashes the program (i will check if i can edit this above...) reproduced also when doing a resize after the rotate...

i put up a question on this topic on the qcad community edition fora

https://www.qcad.org/rsforum/viewtopic.php?f=76&t=7124

rebuilding with 3.24.3.0 as per suggestion from fora (albeit not being optimistic)....

Comment 4 Pontus Enhager 2020-04-06 14:20:21 UTC
Created attachment 1676617 [details]
a qcad.spec patch for 3.24.3.0

a patch for the specfile

Comment 5 Pontus Enhager 2020-04-06 14:43:18 UTC
Created attachment 1676621 [details]
updated patch (old one vs wrong version)

corrected patch to correct version

Comment 6 Fedora Update System 2020-04-06 18:09:26 UTC
FEDORA-2020-c2070a197d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c2070a197d

Comment 7 Fedora Update System 2020-04-06 18:09:28 UTC
FEDORA-2020-86903d5c13 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-86903d5c13

Comment 8 Fedora Update System 2020-04-07 02:28:08 UTC
FEDORA-2020-86903d5c13 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-86903d5c13`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-86903d5c13

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-04-07 03:10:23 UTC
FEDORA-2020-c2070a197d has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c2070a197d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c2070a197d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-04-15 20:33:07 UTC
FEDORA-2020-c2070a197d has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-04-25 02:18:26 UTC
FEDORA-2020-86903d5c13 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Admin user for bugzilla script actions 2020-05-25 14:54:31 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 13 Fedora Admin user for bugzilla script actions 2020-05-26 14:57:47 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 14 Fedora Update System 2020-08-23 10:51:09 UTC
FEDORA-2020-b1590a3506 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b1590a3506

Comment 15 Fedora Update System 2020-08-24 01:47:20 UTC
FEDORA-2020-b1590a3506 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b1590a3506`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b1590a3506

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-08-25 01:05:11 UTC
FEDORA-2020-b1590a3506 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-09-01 13:26:51 UTC
FEDORA-2020-69443441a8 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-69443441a8

Comment 18 Fedora Update System 2020-09-01 13:26:51 UTC
FEDORA-2020-f3c5ed58ed has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f3c5ed58ed

Comment 19 Fedora Update System 2020-09-01 13:26:52 UTC
FEDORA-2020-a69984603b has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a69984603b

Comment 20 Fedora Update System 2020-09-01 18:12:50 UTC
FEDORA-2020-69443441a8 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-69443441a8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-69443441a8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2020-09-01 19:26:15 UTC
FEDORA-2020-f3c5ed58ed has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f3c5ed58ed`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f3c5ed58ed

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2020-09-01 21:48:55 UTC
FEDORA-2020-a69984603b has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a69984603b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a69984603b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2020-09-05 18:32:15 UTC
FEDORA-2020-f3c5ed58ed has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Fedora Update System 2020-09-09 14:20:16 UTC
FEDORA-2020-69443441a8 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 25 Fedora Update System 2020-09-25 16:41:48 UTC
FEDORA-2020-a69984603b has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.