Bug 18213 - TCP timer for TIME_WAIT state breaks
TCP timer for TIME_WAIT state breaks
Status: CLOSED DUPLICATE of bug 16729
Product: Red Hat Linux
Classification: Retired
Component: inetd (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 09:27 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-25 14:26:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of sockets in TIME_WAIT state (2.90 KB, text/plain)
2000-10-03 09:32 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-10-03 09:27:44 EDT
I'm running vmlinux-2.2.14-6.1.1smp on a Dell PowerEdge 2450.  Our 
application connects to numerous POP3 servers on a periodic basis.  We 
monitor the number of sockets in TIME_WAIT state, and observe this number 
going up and down, as expected.  After a while (can be an hour or a day), 
we notice that sockets no longer close, and the number of sockets in 
TIME_WAIT state increase steadily until the kernel crashes (>5000 sockets).

Is this a bug in the TCP/IP stack?  If so, are there any remedies?
Comment 1 Need Real Name 2000-10-03 09:32:26 EDT
Created attachment 3660 [details]
log of sockets in TIME_WAIT state
Comment 2 Pekka Savola 2000-10-03 15:42:27 EDT
Are you synchronizing time on the system?  _Could_ be related to #14876 and friends.
Comment 3 Need Real Name 2000-10-03 15:52:21 EDT
I am using ntp 4.0.99i-1 to sync the clocks amongst various servers.  All other 
time services are off in inetd.conf.
Comment 4 Jeff Johnson 2000-10-06 17:32:14 EDT
Can you run lsof to verify the ownership of the connections?
The output of netstat -a would be helpful as well. Simply knowing the number
of sockets in TIME_WAIT is not enough to identify the cause of the problem.

I'd also double check that the time service is actually off using netstat -a,
as my blind guess is that this problem is #14876 et al as well.
Comment 5 Trond Eivind Glomsrxd 2001-01-19 16:20:36 EST
I'd like to repeat the request for information...
Comment 6 Trond Eivind Glomsrxd 2001-01-25 14:26:07 EST
Can you see if the one at http://people.redhat.com/teg/ helps?
Comment 7 Trond Eivind Glomsrxd 2001-01-30 11:49:24 EST

*** This bug has been marked as a duplicate of 16729 ***

Note You need to log in before you can comment on or make changes to this bug.