Bug 182134 - Fedora core 4 anaconda doesn't go into graphical mode with Samsung SyncMaster 192N monitor
Fedora core 4 anaconda doesn't go into graphical mode with Samsung SyncMaster...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 13:33 EST by charles zhang
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 11:43:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles zhang 2006-02-20 13:33:26 EST
Description of problem:

Anaconda won't start with SamSung SyncMaster 192N

Version-Release number of selected component (if applicable):

Fedora core 4 formal release

How reproducible:

Anaconda doesn't go into graphical mode with Samsung SyncMaster 192N monitor


Additional info:

The display size of this monitor in xorg.conf generated from fedora database is
wrong. The correct size is "380 301", not "380 310".
Comment 1 Phil Knirsch 2006-02-22 08:28:08 EST
hwdata only contains the frequencies of the monitors, not the dimensions.

This is most likely either an anaconda or x11-xorg bug, so i'm reassinging it.

Read ya, Phil
Comment 2 Mike A. Harris 2006-02-22 20:36:06 EST
The xorg-x11 packaging does not have anything to do with X configuration
or with anaconda's install time autodetection of hardware.  Since the bug
report states that this is happening at installation time in anaconda,
then wherever anaconda (or the tools it uses) determines the screen
dimensions from may be incorrect.

Reassigning to anaconda, however it is probably not anaconda which is
directly responsible.

Comment 3 Chris Lumens 2006-02-23 09:50:12 EST
Please retest with FC5 as a good bit of work has happened in this area since FC4.
Comment 4 charles zhang 2006-02-23 10:42:57 EST
Sorry, not going to test with FC5. Please just wait for someone to report it
again after a few hours of struggling with FC5. Maybe no one is using that
monitor anymore, and you guys don't need to bother fixing it.
Comment 6 quintesse 2006-04-03 15:37:45 EDT
Can this be re-opened because this still doesn't work. I was always unable to
install FC4 in graphical mode using my Samsung Syncmaster 913N and now with FC5
I still have the same problem.

It somehow seems to use an unsafe resolution/refresh combination because the
monitor jsut shows colored lines and a warning that the image being displayed is
using a suboptimal resolution. But telling the installer to use specific
resolutions (I tried 640x480, 800x600, 1024x768 and 1280x1024) makes no difference.

If I finally install FC4 or 5 using text mode I can get X to work using either
the vesa or the closed-source nvidia driver. The nv driver installed by default
by the installation just doesn't seem to use the correct settings for the monitor.

I must say that I don't remember correctly anymore, but I think I had to turn
off DDC and modelines manually for the nv driver to work.

Note You need to log in before you can comment on or make changes to this bug.