Bug 1821410 - OperatorHub: operator installation may begin in an invalid state
Summary: OperatorHub: operator installation may begin in an invalid state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1821407
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-06 19:00 UTC by bpeterse
Modified: 2020-05-04 11:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1821407
Environment:
Last Closed: 2020-05-04 11:48:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Crunchy PostgreSQL for OpenShift Operator No Errors (333.61 KB, image/png)
2020-04-15 07:24 UTC, Yadan Pei
no flags Details
OpenShift Pipelines Operator No Errors (300.25 KB, image/png)
2020-04-15 07:31 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4997 None closed [release-4.4] Bug 1821410: Clarify alert for supported operator's install mode 2020-11-09 06:55:01 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:48:58 UTC

Description bpeterse 2020-04-06 19:00:30 UTC
+++ This bug was initially created as a clone of Bug #1821407 +++

Description of problem:

On OperatorHub:
- https://<cluster>/operatorhub/subscribe?pkg=<package>

Sometimes the Create Operator Subscription (Install) form for an operator is generated in a seemingly invalid state. There is no way to install this operator due to "specific namespace" being invalid but the "all namespace" option being unavailable.


Version-Release number of selected component (if applicable): 4.4,4.5


How reproducible:
- always


Steps to Reproduce:
1. Navigate to OperatorHub
2. Choose an operator such as Chruncy PostgreSQL for OpenShift 
3. Click "Install"

Actual results:

- The Create Operator Subscription (Install) form is created, but there is an error banner immediately:
  `Namespace does not support install modes for this Operator`
- The Install Mode is set to "A Specific Namespace"
- The "All Namespace" option is unavailable (disabled/grey text)
- The "Subscribe" button is disabled



Expected results:

- The form should be generated in a usable state.
- The available install options should be correctly enabled/disabled.

Additional info:

Comment 4 Yadan Pei 2020-04-15 07:24:06 UTC
Created attachment 1678939 [details]
Crunchy PostgreSQL for OpenShift Operator No Errors

Comment 5 Yadan Pei 2020-04-15 07:31:42 UTC
Created attachment 1678942 [details]
OpenShift Pipelines Operator No Errors

Comment 6 Yadan Pei 2020-04-15 07:33:09 UTC
Tried operators only enable singlenamespace installation mode && only enable global namespace installation mode
No errors on operator subscription page


Verified on     4.4.0-0.nightly-2020-04-14-222426

Comment 8 errata-xmlrpc 2020-05-04 11:48:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.