Bug 182158 - system-config-services does not maximize
system-config-services does not maximize
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2006-02-20 15:23 EST by Jason
Modified: 2014-06-18 05:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 20:23:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
s-c-services maximized (77.13 KB, image/png)
2006-02-22 08:43 EST, Jason
no flags Details
s-c-services not maximized (76.96 KB, image/png)
2006-02-22 08:44 EST, Jason
no flags Details

  None (edit)
Description Jason 2006-02-20 15:23:48 EST
Description of problem:
system-config-services does not maximize.  If I click the maximize button
nothing happens

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Nils Philippsen 2006-02-21 09:45:58 EST
s-c-services maximises very well here (freshly updated Rawhide system). NB: When
it's busy (reading in info about the services, checking services' statuses) it
might react a bit sluggish.
Comment 2 Jason 2006-02-21 12:36:29 EST
It does not maximize at all for me.  Even after everything is loaded it will not
resize at all.  If I maximize the window, the border disappears, and the window
not move.  If I unmaximize the border reappears and the window will move again.
 What can I do to help get this fixed?

Comment 3 Nils Philippsen 2006-02-22 03:49:35 EST
It would be good if you supplied a bit more details, i.e. what desktop
environment you use, screenshots that exhibit your problem, etc. anything you
can think of that might be relevant to the issue.
Comment 4 Nils Philippsen 2006-02-22 03:53:31 EST
One additional thing: does s-c-services react when you use it while it is in
that not-quite-maximized state?
Comment 5 Jason 2006-02-22 08:42:28 EST
This is a fresh install of FC5T3 plus yesterdays updates (no updates for today
yet).  I am using gnome.  My hardware is a tyan tiger 100 (S1832) motherboard
with 256MB of RAM, Number 9 Revolition IV video card with 32MB of RAM, and a SGI
1600SW LCD monitor.  The resolution I am using is 800x512.  This is a 16:9 monitor.

S-C-services reacts nicely as long as it is not maximized.  I have attached two
Comment 6 Jason 2006-02-22 08:43:19 EST
Created attachment 125026 [details]
s-c-services maximized
Comment 7 Jason 2006-02-22 08:44:05 EST
Created attachment 125027 [details]
s-c-services not maximized
Comment 8 Nils Philippsen 2006-02-22 16:33:20 EST
Please try whether the problem persists with a higher resolution, e.g. 1024x768.
What GTK theme do you use?
Comment 9 Jason 2006-02-23 09:28:37 EST
I use the default theme (bluecurve or whatever is the default for FC5T3).  I
tried s-c-services at 1600x1024 and it works like it should.  The problem is
1600x1024 is too small to get any work done, unless there is a way to change the
default font size the icons on the desktop and msin menu.
Comment 10 Nils Philippsen 2006-02-24 06:12:56 EST
The problem you see is likely to be caused by the window manager (metacity),
I've reproduced it with a number of apps (s-c-services, s-c-date, gimp) if they
are higher than what is available on screen and can't be resized to fit -- if
you click on maximize it doesn't (probably because it can't fit the window
contents on the available screen estate) but still removes the window borders
(as if it had maximized the window).

NB: You can increase your font size by going to System->Preferences->Fonts,
adjust the "Application font" and "Desktop font". Though you might not want to
exactly double their sizes, as your windows mightn't fit on your screen again ;-).
Comment 11 Søren Sandmann Pedersen 2006-09-06 15:31:17 EDT
Should be fixed in RAWHIDE.
Comment 12 Jason 2006-09-09 10:59:23 EDT
still have the problem of s-c-services not maximizing.  reopening.
Comment 13 Nils Philippsen 2006-09-11 05:59:02 EDT
Jason, have youu tested this on FC devel or FC5?
Comment 14 Jason 2006-09-11 10:17:47 EDT
I am using rawhide.
Comment 15 Søren Sandmann Pedersen 2007-03-22 17:12:31 EDT
Jason, are you still seeing this?
Comment 16 Jason 2007-03-23 14:53:50 EDT
I haven't used rawhide since the beginning of December 2006.  I will see if I
can get rawhide installed this weekend and get back to you.
Comment 17 Matthew Miller 2007-04-06 12:08:20 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 18 Jason 2007-04-06 12:58:59 EDT
I tried the FC7T3 Live CD and the problem is still there.  I don't see an option
for FC7 test3 in the version dropdown listbox.
Comment 19 Matthew Miller 2007-04-06 13:04:42 EDT
As of this release, bugs against test versions should be filed against "devel".
This decreases the chances of them getting forgotten about when the real release
(or just the next test release) happens.
Comment 20 Matthias Clasen 2007-09-24 21:30:55 EDT
I can't reproduce this in current rawhide, all system-config utilities I tried
maximize just fine with metacity.
Comment 21 Bug Zapper 2008-04-03 13:00:06 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 22 Bug Zapper 2008-05-06 20:23:04 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.