Bug 1821607 - Metrics chart is too slow to load browsing from Alert/AlertRule page
Summary: Metrics chart is too slow to load browsing from Alert/AlertRule page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-07 08:01 UTC by XiaochuanWang
Modified: 2020-07-13 17:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:25:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
takes about 15 seconds to load chart (9.95 MB, image/gif)
2020-05-18 03:52 UTC, Junqi Zhao
no flags Details
reproduces on 4.5.0-0.nightly-2020-05-18-031304 with Firefox 76.0.1 (3.96 MB, video/quicktime)
2020-05-18 06:49 UTC, XiaochuanWang
no flags Details
Verification screenshot (3.93 MB, video/quicktime)
2020-05-19 02:10 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5478 0 None open Bug 1821607: Query Browser: Fix bug where memo prevented render on width change 2020-06-23 09:51:09 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:26:05 UTC

Description XiaochuanWang 2020-04-07 08:01:34 UTC
Description of problem:
Cluster admin check Alerting page such as Watchdog (or Alerting Rule page), chart is quick enough to show. Click 'View in Metrics' will browse to Metics page and the chart is too slow to show.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-06-184201

How reproducible:
Always

Steps to Reproduce:
1. Cluster admin user goes to Alerting page, such as Watchdog (or from Alerting detail page goes to Alerting Rule page)
2. Check the chart, now it's quick enough to show.
3. Click 'View in Metrics' and check the chart on Metrics page


Actual results:
3. Chart is too slow to show which needs at least 10 seconds.

Expected results:
3. Should show the chart as same speed as in Alerting/Alerting Rule page.

Additional info:
Firefox 74.0

Comment 1 Junqi Zhao 2020-04-13 04:06:57 UTC
Same issue if query metrics directly from Query Browser

Comment 2 Junqi Zhao 2020-05-07 06:12:35 UTC
(In reply to Junqi Zhao from comment #1)
> Same issue if query metrics directly from Query Browser

same issue if query metrics from developer/cluster admin Query Browser

Comment 3 David Taylor 2020-05-11 13:00:13 UTC
We will look into this in the next sprint.

Comment 4 bpeterse 2020-05-15 20:38:31 UTC
I was not able to reproduce this.  I checked Watchdog, as well as several others.  Clicking "show in metrics" loaded the chart reasonably quick each time.

Comment 5 Junqi Zhao 2020-05-18 03:51:32 UTC
(In reply to bpeterse from comment #4)
> I was not able to reproduce this.  I checked Watchdog, as well as several
> others.  Clicking "show in metrics" loaded the chart reasonably quick each
> time.

what is your browser version, we used Firefox/Chrome, it takes 15 seconds to load the chart after clicking "View in Metrics", see the attached gif recorded on Google Chrome	79.0.3945.130 (Official Build) (64-bit)

Comment 6 Junqi Zhao 2020-05-18 03:52:24 UTC
Created attachment 1689507 [details]
takes about 15 seconds to load chart

Comment 7 XiaochuanWang 2020-05-18 06:49:31 UTC
Created attachment 1689535 [details]
reproduces on  4.5.0-0.nightly-2020-05-18-031304 with Firefox 76.0.1

Comment 8 Andrew Pickering 2020-05-18 11:11:00 UTC
This bug was introduced by the change to `useRefWidth` in https://github.com/openshift/console/pull/4841

Comment 12 XiaochuanWang 2020-05-19 02:10:45 UTC
Created attachment 1689730 [details]
Verification screenshot

Comment 13 XiaochuanWang 2020-05-19 02:11:44 UTC
Chart is quickly to show now. Attached the screen recording for refer.
Verified on 4.5.0-0.nightly-2020-05-19-011623

Comment 14 errata-xmlrpc 2020-07-13 17:25:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.