Bug 182161 - Error in /etc/init.d/vncserver script
Error in /etc/init.d/vncserver script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 15:43 EST by Michael Rensing
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.1-36
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 08:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Rensing 2006-02-20 15:43:05 EST
Description of problem:
When the vncserver init.d script runs with the default configuration as
installed, the script fails to start the server, but the message returns "OK"
instead of "FAILED"

Version-Release number of selected component (if applicable):
vnc 4.1.1-10.1

How reproducible:
100%

Steps to Reproduce:
1. Comment out any parameters in /etc/sysconfig/vncservers (this is the default
installed from rpm)
2. 'service vncservers start' (will say "OK")
3. 'service vncservers status' (will say "Xvnc is stopped")
  
Actual results:
see above

Expected results:
'service vncservers start' should say "FAILED"


Additional info:
The problem is that there are no VNCSERVERS defined in /etc/sysconfig/vncservers.


One solution is to add a line to /etc/init.d/vncservers just before starting the
displays and test to see if any VNCSERVERS are defined:

    [ "$VNCSERVERS" = "" ] && RETVAL=1
    for display in ${VNCSERVERS}
Comment 1 Jitka Kozana 2006-03-01 08:52:00 EST
With default cofiguration, no displays will be configured, but vncserver was     
started with no problems, that's why      
/etc/init.d/vncserver start      
says "OK" and      
/etc/init.d/vncserver status    
says "Xvnc is stopped".   
   
Now /etc/init.d/vncserver start will say  
Starting VNC server:no displays configured      [  OK  ]   
 
   
     
Comment 2 Rex Dieter 2006-03-01 09:04:25 EST
IMO, if the service fails to properly start (for any reason, "no displays
configured" or otherwise), it should *not* report [ OK ].

Note You need to log in before you can comment on or make changes to this bug.