Bug 1821702 - firefox starts in a non-resizeable cropped window instead of a maximized window (on Wayland)
Summary: firefox starts in a non-resizeable cropped window instead of a maximized wind...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1815127 (view as bug list)
Depends On:
Blocks: F32FinalBlocker F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-07 12:41 UTC by Kamil Páral
Modified: 2020-04-13 21:28 UTC (History)
22 users (show)

Fixed In Version: gtk3-3.24.18-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-13 21:28:59 UTC
Type: Bug


Attachments (Terms of Use)
bug demonstration video (3.84 MB, application/x-matroska)
2020-04-07 12:42 UTC, Kamil Páral
no flags Details
screenshot in 1920x1080 (1.09 MB, image/png)
2020-04-07 12:44 UTC, Kamil Páral
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gtk - issues 2538 None None None 2020-04-07 13:21:47 UTC
Mozilla Foundation 1623658 P2 RESOLVED [Wayland] Firefox is resized on background 2020-04-24 10:01:35 UTC

Description Kamil Páral 2020-04-07 12:41:38 UTC
Description of problem:
On a clean Fedora 32 Workstation with a clean Firefox profile, Firefox starts in a window that is not maximized neither normal ("non-maximized"). The window doesn't cover the whole screen, but its borders "look" like maximized (there are no shadows, no curved corners), and the window can't be resized. By dragging the title bar or a double click, the window can be reset into normal state (however, it partially jumps offscreen to the right when you do that). Then you can maximize it with another double click or by pulling it to the top GNOME bar. You can use it regularly then. But once you quit Firefox when maximized and start it again, the problem repeats - again you see a cropped window that is neither normal nor maximized and can't be resized.

This only happens on Wayland. On X11, this works fine.

Version-Release number of selected component (if applicable):
firefox-74.0.1-3.fc32.x86_64
gnome-session-wayland-session-3.36.0-2.fc32.x86_64
gnome-shell-3.36.1-2.fc32.x86_64
gtk3-3.24.16-1.fc32.x86_64
libwayland-client-1.18.0-1.fc32.x86_64
libwayland-cursor-1.18.0-1.fc32.x86_64
libwayland-egl-1.18.0-1.fc32.x86_64
libwayland-server-1.18.0-1.fc32.x86_64
mutter-3.36.1-3.fc32.x86_64
xorg-x11-server-Xwayland-1.20.8-1.fc32.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot F32 Workstation, log in under Wayland
2. $ rm ~/.mozilla/ ~/.cache/mozilla/ -rf  # warning, this will erase all firefox data
3. run Firefox
4. depending on your resolution, either Firefox starts in "maximized" mode (but broken, as described here), or normal mode
5. maximize Firefox
6. close and start Firefox again
7. Firefox should again be in a broken window state, as described

Comment 1 Kamil Páral 2020-04-07 12:42:34 UTC
Created attachment 1676934 [details]
bug demonstration video

This video demonstrates the problem.

Comment 2 Kamil Páral 2020-04-07 12:44:32 UTC
Created attachment 1676935 [details]
screenshot in 1920x1080

In 1920x1080, the problem is even more visible, because "maximized" Firefox window occupies only around half the screen.

Comment 3 Kamil Páral 2020-04-07 12:47:02 UTC
Proposing as an F32 Final blocker, because either Firefox or the windowing system doesn't work correctly, preventing users from using maximized applications comfortably.

Comment 5 Kamil Páral 2020-04-07 13:43:28 UTC
Hello Jonas, you implemented the fix in gtk for this. Do you think we can get a fixed gtk version in Fedora 32 in the next few days? Or should I bother somebody else? Thanks.

Comment 6 Jonas Ådahl 2020-04-07 14:35:26 UTC
It was included in https://bodhi.fedoraproject.org/updates/FEDORA-2020-8ced3e4e6b which was unpushed due to regressions. It'll be available in 3.24.18 which will happen relatively soon I think.

Comment 7 Martin Stransky 2020-04-09 19:26:00 UTC
*** Bug 1815127 has been marked as a duplicate of this bug. ***

Comment 8 Adam Williamson 2020-04-09 19:31:54 UTC
I'm at least +1 FE on this, for the record.

Comment 9 Fedora Update System 2020-04-10 10:08:38 UTC
FEDORA-2020-ac3dfd7904 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ac3dfd7904

Comment 10 Fedora Update System 2020-04-11 18:51:33 UTC
FEDORA-2020-ac3dfd7904 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-ac3dfd7904`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-ac3dfd7904

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 František Zatloukal 2020-04-12 09:41:38 UTC
FEDORA-2020-ac3dfd7904 fixes the issue. Firefox now starts maximized even if it was closed as not-maximized window previously, but if this is a bug at all, it is a different issue.

Comment 12 Geoffrey Marr 2020-04-13 19:33:31 UTC
Discussed during the 2020-04-13 blocker review meeting: [0]

The decision to delay the classification of this bug as a blocker and accept it as an "AcceptedFreezeException" was made as it's a close call whether this is bad enough to be a blocker and we don't have a clear decision on that, but we definitely accept it as an FE and the update to fix it has strong positive feedback, so we expect to push that and resolve the bug.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-04-13/f32-blocker-review.2020-04-13-16.04.txt

Comment 13 Fedora Update System 2020-04-13 21:28:59 UTC
FEDORA-2020-ac3dfd7904 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.