Bug 182191 - Search unusable in FC5T3
Search unusable in FC5T3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 17:31 EST by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 07:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2006-02-20 17:31:23 EST
Description of problem:
The new Places > Search seems non-functional.  When I enter "fedora"
into the Find: field, it first says the daemon is not running.  After I
start the daemon with the provided button, it then returns No results
were found.  

Then, while I was writing a post to feora-test-list it came up with a list of
Conversations
that it found - from Evolution posts to this list.

No files were reported, though locate could find many containing "fedora".
Version-Release number of selected component (if applicable):
[root@fc5t3 ~]# rpm -q beagle
beagle-0.2.1-6

How reproducible:
Always

Steps to Reproduce:
1.Select menu Places > Search
2.Enter search string ("fedora") in Find: box
3.
  
Actual results:
Daemon is not running, After daemon runs, no files found

Expected results:
A list of files containing "fedora" should be output.

Additional info: Fresh install of FC5T3 from DVD.
Comment 1 Wade Mealing 2006-02-21 09:05:52 EST
The beagle daemon only indexes your home directory by default.  If you have no
files with the word "fedora" in your home directory then you may find it will
return nothing.

There is also the use-case where the first time that the daemon is run, it will
start to index your home directory, untill data with the word "Fedora" in it is
indexed, it will not return any valid results.

First question: 
Do you think it is a bug that the search daemon is not started by default ?

Second question:
Can you reproduce this behavior again , after the system has had time to index
your home directory ?


Comment 2 Gerry Tool 2006-02-21 09:49:41 EST
Thanks for the reply.

Answer to First question:
Yes, I think it is a bug that the daemon is not started by default.  When I use
whatever GUI search tool is provided, I expect it to come up running in a useful
way. The user shouldn't have to start the search daemon and then wait for
indexing to occur.

Answer to Second question:
Yes, this time after about a minute, the Conversations category came up with
results, and a second category Documents came up with some results from
signatures to mail-list postings.

A question from me:
Why doesn't indexing occur for the whole system instead of the home directory? 
I am frequently looking for some system file when I do a search.

Another question:
How can I make the daemon start automatically, and how can I make the indexing
occur globally?

Yet another question:
Does the indexing follow links in the home directory?  Since I use several Linux
systems installed on the same computer and want my data available from each of
them and want it to persist when I install a new system, I keep all data in a
separate partition and link to it in my home directory.  If indexing doesn't
follow links, then the search doesn't even do an adequate job of finding any of
my own data files.

I think the answer is that links are not followed, since personal files and my
personal e-mail folders in my data partition did not pop up in the search.

Thanks.  Gerry
Comment 3 Matthias Clasen 2006-02-21 15:18:41 EST
So, indexing of the whole system is done by a cron job running
/usr/libexec/beagle-crawl-system. Unfortunately, it was installed as a
cron job, so it only worked if your system was up at 4:30am.

I have changed it to an anacron job in beagle-0.2.1-8

It also installs an autostart file now, which causes the daemon
to run in user sessions by default.
Comment 4 Gerry Tool 2006-02-24 13:28:18 EST
The daemon now starts automatically.  I have selected / to be indexed as well as
my home directory.  When I enter "fedora" without the quotations in the search
box, it still only shows items from mail messages.  Locate finds mamy files on
my system with "fedora" in the name.

Why doesn't beagle find them?

What can I send you to help in understanding the problem?

[gerry@fc5t3 ~]$ rpm -q beagle
beagle-0.2.1-11
Comment 5 Alexander Larsson 2006-08-14 07:54:46 EDT
beagle-search only searches the files in your home directory and the additional
paths that you set up in the search preferences. The system indexed stuff that
gets run in cron is only searched by the help system (yelp).

This is a design decision to avoid "normal user searches" become full of system
files. If you want to do things differently you need to set up additional
indexing paths.

Note You need to log in before you can comment on or make changes to this bug.