Bug 1821932 - installer-gather log path emitted is incorrect/confusing
Summary: installer-gather log path emitted is incorrect/confusing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: John Hixson
QA Contact: Yunfei Jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-07 20:54 UTC by Aleksandar Kostadinov
Modified: 2020-07-13 17:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:26:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3489 0 None closed bug 1821932: cmd/openshift-install/gather: clarify location of log bundle 2020-07-14 03:03:21 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:26:21 UTC

Description Aleksandar Kostadinov 2020-04-07 20:54:16 UTC
This bug was initially created as a copy of Bug #1811453

Description of problem:

When bootstrap process fails, openshift-installer tries to obtain debug logs by performing an SSH connection to the bootstrap machine. For this to work, during installation user needs to specify an SSH public key and have private key under ~/.ssh

issue is that installer log does not point at correct log bundle location. In log I see

> DEBUG Log bundle written to /var/home/core/log-bundle-20200308190642.tar.gz

while bundle is actually generated as

> install-dir/log-bundle-20200308190642.tar.gz

Version-Release number of the following components:
bash-4.2$ workdir/openshift-install version
workdir/openshift-install 4.4.0-0.nightly-2020-03-07-113547
built from commit f371355517f9da267c295e11c01cd3dfc54b39d4
release image registry.svc.ci.openshift.org/ocp/release@sha256:f616ef3c31ea273818d511a61396bba3e49ef20fce86a51d0fb290b9cf5a0894

How reproducible:
always

Steps to Reproduce:
1. run IPI installer
2. bootstrap should fail (not sure how to cause this)

Actual results:

> DEBUG Log bundle written to /var/home/core/log-bundle-20200308190642.tar.gz

Expected results:

> DEBUG Log bundle written to install-dir/log-bundle-20200308190642.tar.gz

Comment 2 John Hixson 2020-04-21 21:51:13 UTC
The script that runs is located remotely. I think the debug statement should stay as-is. It is only printed when --log-level debug is specified to the installer. I have opened a PR to clarify where the log bundle is stored locally when retrieved and it sticks out and should make it clear.

PR: https://github.com/openshift/installer/pull/3489

Comment 6 Yunfei Jiang 2020-04-23 03:10:38 UTC
verified on 4.5.0-0.nightly-2020-04-22-235941

Comment 7 errata-xmlrpc 2020-07-13 17:26:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.