Bug 1821990 - Filter alert by name can't work
Summary: Filter alert by name can't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-08 02:40 UTC by hongyan li
Modified: 2020-07-13 17:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:26:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
filter alert (77.23 KB, image/png)
2020-04-08 02:40 UTC, hongyan li
no flags Details
filter alert rule (56.51 KB, image/png)
2020-04-08 07:04 UTC, hongyan li
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4968 0 None closed Bug 1821990: Monitoring: Change text filter by alert description to not use fuzzy 2020-06-23 09:52:52 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:26:21 UTC

Description hongyan li 2020-04-08 02:40:55 UTC
Created attachment 1677093 [details]
filter alert

Created attachment 1677093 [details]
filter alert

Description of problem:
Alerts list page text filter should filter by name and description. Input 'Watchdog' in the filter box, the AlertmanagerReceiversNotConfigured alert is still shown. there is not such issue if we input AlertmanagerReceiversNotConfigured in the filter box

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-07-211130

How reproducible:
always

Steps to Reproduce:
1.open alert list page
2.Input 'Watchdog' in the filter box
3.Filter doesn't work

Actual results:
Alerts list page text filter can't work, all the alerts display

Expected results:
Alerts list page text filter should filter by name, only alert Watchdog display

Additional info:
screenshot provided

Comment 2 hongyan li 2020-04-08 03:20:00 UTC
Filter alert rules works, please ignore the previous comments

Comment 3 hongyan li 2020-04-08 07:04:56 UTC
Created attachment 1677144 [details]
filter alert rule

Comment 6 hongyan li 2020-04-15 06:38:43 UTC
Test with payload release:4.5.0-0.nightly-2020-04-14-221451
Filter alerts with name works well

Comment 7 David Taylor 2020-05-07 15:46:18 UTC
*** Bug 1798452 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2020-07-13 17:26:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.