Bug 1822122 - oauth-server is missing password metrics
Summary: oauth-server is missing password metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Standa Laznicka
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks: 1823772
TreeView+ depends on / blocked
 
Reported: 2020-04-08 10:14 UTC by Standa Laznicka
Modified: 2020-07-13 17:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: upstream code-change caused the password metrics to be missing in the oauth-server Consequence: you couldn't check the password metrics of the oauth-server Fix: use the now non-default way to register metrics Result: the oauth-server now provides password metrics again
Clone Of:
: 1823772 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:26:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oauth-server pull 37 0 None closed Bug 1822122: Add back some missing metrics 2021-02-10 08:01:26 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:26:21 UTC

Description Standa Laznicka 2020-04-08 10:14:04 UTC
Description of problem:
the metrics described in https://docs.openshift.com/container-platform/4.3/authentication/understanding-authentication.html#authentication-prometheus-system-metrics_understanding-authentication are missing


Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1. curl https://<oauth-server-route>/metrics

Actual results:
metrics from the docs are not there

Expected results:
the metrics are there

Comment 4 errata-xmlrpc 2020-07-13 17:26:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.