Bug 1822199 - Support Pipeline Operator TechPreview - Pipeline Builder
Summary: Support Pipeline Operator TechPreview - Pipeline Builder
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1821420
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-08 13:29 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1821420
Environment:
Last Closed: 2020-05-04 11:48:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
support pipeline operator tp- pipeline builder (43.70 KB, image/png)
2020-04-22 10:29 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5006 None closed [release-4.4] Bug 1822199: Support TechPreview Task Changes 2020-05-04 14:16:34 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:49:02 UTC

Description Andrew Ballantyne 2020-04-08 13:29:35 UTC
+++ This bug was initially created as a clone of Bug #1821420 +++

Description of problem:
The release of the OpenShift Pipelines Operator TechPreview has changed the way the Tasks and ClusterTasks are structured, this has broken Pipeline Builder 

Version-Release number of selected component (if applicable):
OpenShift Console 4.4
OpenShift Pipeline Operator 1.0

How reproducible:


Steps to Reproduce:
1. Navigate to the Pipeline Builder (create button on the Pipeline resource)
2. Select the `buildah` from the task dropdown
3. Select the `buildah` node

Actual results:
Sidebar shows only a name

Expected results:
Sidebar should show multiple Parameters, One Input Resource and One Output Resource.


Additional info:
v1alpha1 should be backwards compatible
v1beta1 should be supported

--- Additional comment from Andrew Ballantyne on 2020-04-06 20:42:14 UTC ---

Related Jira: https://issues.redhat.com/browse/ODC-3493

Comment 3 spathak@redhat.com 2020-04-22 10:29:56 UTC
Created attachment 1680801 [details]
support pipeline operator tp- pipeline builder

Comment 4 spathak@redhat.com 2020-04-22 10:31:07 UTC
Verified on build: 4.4.0-0.ci-2020-04-17-081422
Verified on firefox 69.0

Comment 6 errata-xmlrpc 2020-05-04 11:48:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.