Bug 182220 - Kudzu fails with segfault on FC5 Test 3 on HP Pavilion ZE2108WM Notebook
Kudzu fails with segfault on FC5 Test 3 on HP Pavilion ZE2108WM Notebook
Status: CLOSED DUPLICATE of bug 179013
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 23:44 EST by Stanton Finley
Modified: 2014-03-16 22:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 12:08:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanton Finley 2006-02-20 23:44:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051003 Firefox/1.0.7

Description of problem:
Kudzu fails with segfault on FC5 Test 3 on HP Pavilion ZE2108WM Notebook with the message "Checking for hardware changes/etc/rc5.d/S05kudzu: line 23: 1357 Segmentation fault /sbin/kudzu $KUDZU_ARGS [FAILED]".

This occurs with SELinux enabled or disabled or upon relabeling.

The notebook uses a 1.6 GHz AMD Mobile Sempron™ Processor 2800+ with PowerNow!™ Technology.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1955_FC5hypervisor-i686

How reproducible:
Always

Steps to Reproduce:
1. Boot FC5test3 on a on HP Pavilion ZE2108WM Notebook.

Actual Results:  Kudzu fails with segfault on FC5 Test 3 on HP Pavilion ZE2108WM Notebook with the message "Checking for hardware changes/etc/rc5.d/S05kudzu: line 23: 1357 Segmentation fault /sbin/kudzu $KUDZU_ARGS [FAILED]".

Expected Results:  Kudzu should not segfault on boot.

Additional info:

The output of lspci for this machine is:

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc: Unknown device 4378 (rev 02)
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
05:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
Comment 1 Thomas M Steenholdt 2006-02-21 01:15:11 EST
Same for me on a Shuttle Pentium-M based system...

Kudzu works fine with the normal non-hypervisor kernel.
Comment 2 Stanton Finley 2006-02-21 01:41:46 EST
The problem is resolved by installing the non-hypervisor kernel and removing
kernel-2.6.15-1.1955_FC5hypervisor-i686. Should the hypervisor kernel be
installed on this processor by default?
Comment 3 Thomas M Steenholdt 2006-02-21 11:22:17 EST
The hypervisor kernel should really only be installed if selecting to install
Xen. Also I'd expect kudzu to work even under the hypervisor kernel.
Comment 4 Bill Nottingham 2006-02-21 12:08:17 EST

*** This bug has been marked as a duplicate of 179013 ***

Note You need to log in before you can comment on or make changes to this bug.