Bug 182222 - can't use ssh/scp inside of anaconda and rescue mode
can't use ssh/scp inside of anaconda and rescue mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-21 00:21 EST by Dax Kelson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 14:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2006-02-21 00:21:59 EST
Description of problem:

When installing FC5 test releases or rawhide I've noticed that during the
install or inside of a rescue environment (very important!) I'm unable to use
ssh or scp.

It looks like this:

# scp localfile.txt 1.2.3.4:/tmp
Host key verication failed.
lost connection

Using verbose mode swich reveals this clue:

[snip a bunch of output]
debug1: read_passphrase: can't open /dev/tty: No such device or address
Host key verication failed.
lost connection
Comment 1 Jeremy Katz 2006-02-21 10:59:31 EST
Hmm, it's working just fine for me with today's rawhide.  Does /dev/tty exist? 
What type of hardware and what install type are you using?
Comment 2 Dax Kelson 2006-02-21 11:39:30 EST
Did you try the rescue mode?

/dev/tty did exist

I was installing 32bit FC5test3 on AMD64 hardware.
Comment 3 Jeremy Katz 2006-02-22 16:12:01 EST
Aha, it's only a problem on tty and is fine on tty2.  And this is also related
to your problems with ctrl-c.  Why accessing /dev/tty from tty1 is returning
ENXIO is what I'm not clear on right now...
Comment 4 David Cantrell 2006-03-03 14:06:32 EST
This problem has been corrected in CVS.  The tty1 shell doesn't get ENXIO when
accessing /dev/tty now.  I also modified init so that when you've booted rescue
mode, the Ctrl+C, Ctrl+Z, and friends are not disabled.

Note You need to log in before you can comment on or make changes to this bug.