Bug 18223 - rpm which starts executable from cd locks the cdrom
Summary: rpm which starts executable from cd locks the cdrom
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-03 15:34 UTC by Andrew McCallum
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 15:34:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew McCallum 2000-10-03 15:34:30 UTC
An RPM I created which installs several files and binaries, and then 
starts a few of those binary daemons from the hard disk locks the cdrom 
drive when the RPM is installed from the cd, although the files are 
executing from the hard disk, and no other file or user is accessing the 
cdrom.

Comment 1 Jeff Johnson 2000-10-03 16:38:37 UTC
rpm does no cdrom locking whatsoever. Perhaps you have the cdrom drive mounted,
as
a mount (with associated open) locks the cdrom ...

Comment 2 Andrew McCallum 2000-10-03 17:31:07 UTC
The cdrom was mounted for the purpose of installing the rpm, which was located 
on a CD.  The problem is that the cdrom would not UNMOUNT after installing the 
package, claiming that executables started by the RPM were using the device, 
even though they were running from the hard drive, not the CD.

Comment 3 Jeff Johnson 2000-10-03 17:54:36 UTC
But I'll bet that the you executed the binaries while the current working
directory
was /mnt/cdrom /...  That will cause a reference to the cdrom ...

Comment 4 Andrew McCallum 2000-10-03 18:45:28 UTC
Ahhh, verstehe ich.  Something to try at least...thanks.

Comment 5 Andrew Bartlett 2000-10-12 09:38:29 UTC
Could RPM do a chdir to / before running the included scripts?  Some packages
execute a /etc/rc.d/init.d/whatever restart from the script, and could cause
this problem.

Comment 6 Andrew McCallum 2000-10-12 13:25:57 UTC
Yes, this is more or less what I did.  Making the current working directory 
something not-the-cdrom and executing from there does the trick nicely.


Note You need to log in before you can comment on or make changes to this bug.