Bug 1822331 - Add workload badge/name to monitoring dashboard when navigating to it from the Side Panel monitoring tab
Summary: Add workload badge/name to monitoring dashboard when navigating to it from th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1828253
TreeView+ depends on / blocked
 
Reported: 2020-04-08 18:42 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1828253 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:26:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
Monitoring page having deployment name (136.04 KB, image/png)
2020-04-27 10:55 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5133 0 None closed Bug 1822331: Add workload badge/name to monitoring dashboard when navigating to it from the Side Panel monitoring tab 2020-06-23 09:54:23 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:03 UTC

Description Andrew Ballantyne 2020-04-08 18:42:10 UTC
Description of problem:
Navigation through the Topology page sidebar to the Monitoring page comes with an implicit context that the content shown is related to the selected workload from the Topology page. This is however not conveyed at all to the user.

Version-Release number of selected component (if applicable):
OpenShift 4.4

How reproducible:


Steps to Reproduce:
1. Deploy a workload through one of the add flows
2. Select the workload on the Topology page
3. Select the Monitoring tab in the sidebar
4. Click on the "View monitoring dashboard" link under the Metrics section

Actual results:
Takes you to the Monitoring Dashboard without explaining the context of the charts

Expected results:
To see that the Monitoring Dashboard is being filtered down to the workload and not representing what the Monitoring Dashboard normally represents, which is all workloads.

Additional info:

Comment 5 Gajanan More 2020-04-27 10:53:57 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-04-26-162607
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 6 Gajanan More 2020-04-27 10:55:55 UTC
Created attachment 1682115 [details]
Monitoring page having deployment name

Comment 7 errata-xmlrpc 2020-07-13 17:26:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.