Bug 1822336 - Default Utilities folder renamed to X-GNOME-Utilities.directory
Summary: Default Utilities folder renamed to X-GNOME-Utilities.directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-08 18:52 UTC by angel.segarra
Modified: 2020-04-13 21:29 UTC (History)
17 users (show)

Fixed In Version: gnome-shell-3.36.1-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-13 21:29:09 UTC
Type: Bug


Attachments (Terms of Use)

Description angel.segarra 2020-04-08 18:52:27 UTC
Description of problem:

How reproducible:

Fresh Fedora 32 install using Everything ISO


Actual results:
Utilities folder is named X-GNOME-Utilities.directory

Expected results:
Folder should be named Utilities

Comment 1 Daniel Rusek 2020-04-12 18:38:07 UTC
This is a gnome-shell regression, see: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2623

Comment 2 Fedora Blocker Bugs Application 2020-04-12 19:04:46 UTC
Proposed as a Freeze Exception for 32-final by Fedora user asciiwolf using the blocker tracking app because:

 GNOME Shell regression caused the default Utilities folder (and possibly other folders as well) to be displayed as "X-GNOME-Utilities.directory" in Shell Overview. This goes against the otherwise well polished Fedora design, looks unprofessional and confusing to users. There is already an upstream fix for this regression available.

Comment 3 Michal Konecny 2020-04-12 19:16:25 UTC
+1 FE

Comment 4 Fedora Update System 2020-04-13 19:00:50 UTC
FEDORA-2020-772fb1c028 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-772fb1c028

Comment 5 František Zatloukal 2020-04-13 19:11:10 UTC
FEDORA-2020-772fb1c028 fixes the issue.

Comment 6 Geoffrey Marr 2020-04-13 19:45:29 UTC
Discussed during the 2020-04-13 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-04-13/f32-blocker-review.2020-04-13-16.04.txt

Comment 7 Fedora Update System 2020-04-13 21:18:04 UTC
FEDORA-2020-772fb1c028 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-772fb1c028`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-772fb1c028

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-04-13 21:29:09 UTC
FEDORA-2020-772fb1c028 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.