Bug 182236 - Totem-mozplugin takes over capabilities it does not have
Totem-mozplugin takes over capabilities it does not have
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 05:24 EST by Ivan Gyurdiev
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 11:20:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2006-02-21 05:24:16 EST
Totem takes over the following when totem-plugin is installed:

video/quicktime 	QT video 	mov 	Yes
application/x-mplayer2 	AVI video 	avi, wma, wmv 	Yes
video/mpeg 	MPEG video 	mpg, mpeg, mpe 	Yes
video/x-ms-asf-plugin 	ASF video 	asf, wmv 	Yes
video/x-ms-wmv 	WMV video 	wmv 	Yes
application/ogg 	Ogg multimedia 	ogg 	Yes
application/x-google-vlc-plugin 	Google VLC plugin 		Yes
application/x-vlc-plugin 	VideoLAN plugin 		Yes
audio/wav 	WAV audio 	wav 	Yes

Yet it is not capable of playing MPEG video... when I attempt to play mpeg video
with totem it locks up the browser. The same happens with quicktime. There's no
error message of any kind - just locks up. On the other hand when such content
is ran through totem (the standalone application) it complains about missing codecs.

I know that totem uses gstreamer, and at the moment I don't have 64-bit mpeg
support for gstreamer installed. However, that's not the point of this bug.

mozplugger is able to successfully play all content that I'm interested in.
However, totem-mozplugger overrides it when installed, which is particularly
evil. Totem should know exactly what it can and can't play, and shouldn't take
over file extensions it is unable to handle.
Comment 1 John (J5) Palmieri 2006-02-21 11:20:00 EST
Please file this bug upstream at bugzilla.gnome.org.  totem-mozplugin is highly
experimental and was enabled but not installed by default because there were
requests for it.  Solution is to remove the packages for now and file the bug
upstream as they are in a better possition to fix the issues.

Note You need to log in before you can comment on or make changes to this bug.