Bug 1822396 - subscription_sync_total metric potentially not getting removed
Summary: subscription_sync_total metric potentially not getting removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Anik
QA Contact: kuiwang
URL:
Whiteboard:
Depends On:
Blocks: 1850237
TreeView+ depends on / blocked
 
Reported: 2020-04-08 21:47 UTC by Anik
Modified: 2020-10-27 15:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1850237 (view as bug list)
Environment:
Last Closed: 2020-10-27 15:57:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1519 0 None closed Bug 1822396: Delete subscription metric when an operator is uninstalled 2020-09-14 02:46:27 UTC
Github operator-framework operator-lifecycle-manager pull 1603 0 None closed Bug 1822396: Update metric when Subscription is updated 2020-09-14 02:46:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:14 UTC

Description Anik 2020-04-08 21:47:07 UTC
Description of problem:

Metrics for Subscriptions of CSVs that have been upgraded to new versions still hang around after new Subscription/CSV have succeeded. 

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Install ocs-operator.v4.2.2 
2. Upgrade to ocs-operator.v4.2.3
3. Check metrics emitted for csv_succeded

Actual results:

Metrics for both ocs-operator.v4.2.2 and ocs-operator.v4.2.3 are been emitted

Expected results:

Only Subscription metric for ocs-operator.v4.2.3 show up

Additional info:

Comment 13 errata-xmlrpc 2020-10-27 15:57:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.