Bug 182246 - [oocalc] default indic "number" display format is not [NatNum1], though date/time are
[oocalc] default indic "number" display format is not [NatNum1], though date/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2006-02-21 07:48 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 05:28:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-02-21 07:48:08 EST
Description of problem:
Using scim as the input method, indic numeric characters cannot be successfully
committed into each cell. After moving to another cell after entering the indic
numeric characters, they gets converted automatically back to english numeric
characters.

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.1.1-11.2.2
scim-1.4.4-4.1
scim-m17n-0.2.0-1
m17n-db-bengali-1.3.2-2

How reproducible:
Always

Steps to Reproduce:
1.start oocalc with bn_IN locale, bn_IN.UTF-8 oocalc
2.select any cell and activate SCIM (ctrl-SPACE)
3.ensure bengali IME (M17N-bn-probhat) is selected from the scim manager found
in systray
4.enter 12345  
5. use -left or right arrow key to move to the next cell

Actual results:
indic numeric character changed to english numeric

Expected results:
indic numeric

Additional info:
if indic numeric characters are combine with indic characters, the conversion
wont happen.
Comment 1 Caolan McNamara 2006-02-21 11:15:37 EST
weird, it's *only* with calc, they *stick* as bengali in writer, and in the
shared drawing layer code of drawing textboxes and so forth.
Comment 2 Caolan McNamara 2006-02-21 13:48:49 EST
Ah yes, F11 for style list, right click on default, modify -> numbers select
number category and fill in [NatNum1]0 for format code and calc "does the right
thing", You'll see that dates and times are already in [NatNum1] mode. 

So this isn't a bug per-se, but instead an enhancement request to make the
number default as [NatNum1]. Spreadsheets are tricky things.
Comment 3 Caolan McNamara 2006-02-22 05:28:55 EST
ok, thinking through this there isn't any action that we should or could take.

If you combine text and numbers you end up with text, and as such text is
displayed as "format text", the same as was entered. Numbers only is a different
beast.

If you enter just numbers, either standard arabic numberals or bengali ones, or
the numerals of *any* language, then they are auto-detected as numbers,
converted to internal numbers and then displayed as "format number" with the
number formatting code in use. i.e. all numbers are displayed the same way,
whether entered using bengali numerals or arabic ones. It isn't possible to
distinguish between 12345 or ১২৩৪৫ because they are the same thing to calc once
detected as numbers.

calc always uses "standard" as the default number formatting, which is arabic
numbers in all locales. If a user wants to display in the "local" locale's
number formatting he has to use number formatting "[NatNum1]0". Or if he wants
to enter "text" that consists of only numbers, then he must use text formatting.

Setting the default as [NatNum1]0 just for bengali doesn't make sense, it would
have to be done for all languages, and doing means that entering literal arabic
"12345" would automatically be detected as numbers and then displayed as the
equivalent Bengali digits, so either way there is a scenario where the text
entered is not the text displayed.

Note You need to log in before you can comment on or make changes to this bug.