Bug 1822515 - API upgrade monitoring in CI should distinguish between kube and openshift APIs
Summary: API upgrade monitoring in CI should distinguish between kube and openshift APIs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.0
Assignee: Stefan Schimanski
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1822514
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-09 08:56 UTC by Stefan Schimanski
Modified: 2020-05-04 11:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1822514
Environment:
Last Closed: 2020-05-04 11:48:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24852 None closed Bug 1822515: 4.4 - tests: split API availability monitor into kube and OpenShift 2020-04-21 15:49:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:49:02 UTC

Description Stefan Schimanski 2020-04-09 08:56:10 UTC
+++ This bug was initially created as a clone of Bug #1822514 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Ke Wang 2020-04-16 03:45:24 UTC
Per PR https://github.com/openshift/origin/pull/24844, do the following checking with fixed OCP build 4.4.0-0.nightly-2020-04-14-192407 which found the following in log https://storage.googleapis.com/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-upgrade/25567/artifacts/e2e-aws-upgrade/container-logs/test.log,
,
STEP: Building a namespace api object, basename openshift-api-available
STEP: Building a namespace api object, basename kubernetes-api-available

They were new as mentioned in PR. So the bug has been fixed, move it verify.

Comment 5 errata-xmlrpc 2020-05-04 11:48:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.