Bug 182253 - nscd cache pollution
nscd cache pollution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks: RHEL3U8CanFix
  Show dependency treegraph
 
Reported: 2006-02-21 09:28 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0453
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 10:28:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
glibc-rh182253.patch (3.29 KB, patch)
2006-04-04 10:11 EDT, Jakub Jelinek
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-02-21 09:28:40 EST
nscd-2.3.2-95.37

With nscd running:
$ /etc/init.d/nscd restart
Stopping nscd:                                             [  OK  ]
Starting nscd:                                             [  OK  ]
$ service nscd status
nscd (pid 8249) is running...
$ grep ncsu /etc/hosts
127.0.0.2               www.ncsu.edu
$ getent hosts www.ncsu.edu
127.0.0.2       www.ncsu.edu
$ getent hosts www.ncsu.edu.
152.1.226.10    uni200v.unity.ncsu.edu www.ncsu.edu
$ getent hosts www.ncsu.edu
152.1.226.10    uni200v.unity.ncsu.edu www.ncsu.edu

Without nscd running:
$ /etc/init.d/nscd stop
Stopping nscd:                                             [  OK  ]
$ getent hosts www.ncsu.edu
127.0.0.2       www.ncsu.edu
$ getent hosts www.ncsu.edu.
152.1.226.10    uni200v.unity.ncsu.edu www.ncsu.edu
$ getent hosts www.ncsu.edu
127.0.0.2       www.ncsu.edu
Comment 5 Jakub Jelinek 2006-04-04 10:11:30 EDT
Created attachment 127297 [details]
glibc-rh182253.patch

This should hopefully fix it, it is not really a backport, since hstcache.c
was almost rewritten a few days before the corresponding patch has been
committed.  With this patch, we should only cache using request key as being
passed from the client, rather than cache also with the reverse mapping and all
aliases and IP{,v6} addresses associated with it as other keys.
Comment 7 Bob Johnson 2006-04-11 12:05:09 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.
Comment 11 Red Hat Bugzilla 2006-07-20 10:28:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0453.html

Note You need to log in before you can comment on or make changes to this bug.