Bug 1822597 - gstreamer-plugins- bad/bad-nonfree/ugly obsoleted needlessly
Summary: gstreamer-plugins- bad/bad-nonfree/ugly obsoleted needlessly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-09 13:07 UTC by ozeszty
Modified: 2020-05-07 03:10 UTC (History)
3 users (show)

Fixed In Version: fedora-obsolete-packages-32-48
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-07 03:10:14 UTC
Type: Bug


Attachments (Terms of Use)

Description ozeszty 2020-04-09 13:07:13 UTC
Description of problem:
fedora-obsolete-packages needlessly obsoletes gstreamer-plugins-bad (also bad-nonfree and ugly) from rpmfusion and blocks upgrade to F32. Those packages were obsoleted last august in rpmfusion.

It would be nice if those issues were caught in transaction check, before rebooting to system-upgrade, otherwise user have to look through journalctl in serarch for what caused upgrade failure, remove problematic package, and rerun both steps of system-upgrade just to find out that another package has the same issue.

Version-Release number of selected component (if applicable):
fedora-obsolete-packages-32-44.noarch

How reproducible:
On F30

Steps to Reproduce:
1. install gstreamer-plugins-bad etc. from rpmfusion on F30
2. dnf system-upgrade download --refresh --releasever=32
3. dnf system-upgrade reboot

Actual results:
Upgrade fails and system reboots still on F30.

kwi 09 00:44:32 Rodzice dnf[612]: Błąd:
kwi 09 00:44:32 Rodzice dnf[612]:  Problem: both package rpmfusion-free-obsolete-packages-32-1.fc32.noarch and fedora-obsolete-packages-32-44.noarch obsolete gstreamer-plugins-bad < 0.10.23-14
kwi 09 00:44:32 Rodzice dnf[612]:   - conflicting requests

same for gstreamer-plugins-ugly

and:
Problem: both package rpmfusion-nonfree-obsolete-packages-31-1.fc32.noarch and fedora-obsolete-packages-32-44.noarch obsolete gstreamer-plugins-bad-nonfree < 0.10.23-11


Additional info:
From rpmfusion rpmfusion-*-obsolete-packages spec's:

# Last build gstreamer-plugins-bad-nonfree-0.10.23-10.fc31
Provides: gstreamer-plugins-bad-nonfree = 0.10.23-11
Obsoletes: gstreamer-plugins-bad-nonfree < 0.10.23-11

# Last build gstreamer-ffmpeg-0.10.13-22.fc31
Provides: gstreamer-ffmpeg = 0.10.13-23
Obsoletes: gstreamer-ffmpeg < 0.10.13-23
# Last build gstreamer-plugins-bad-0.10.23-13.fc31
Provides: gstreamer-plugins-bad = 0.10.23-14
Obsoletes: gstreamer-plugins-bad < 0.10.23-14
# Last build gstreamer-plugins-ugly-0.10.19-33.fc31
Provides: gstreamer-plugins-ugly = 0.10.19-34
Obsoletes: gstreamer-plugins-ugly < 0.10.19-34

PS These 'Provides:' statements shouldn't be there, right?

Comment 1 Xavier Bachelot 2020-05-06 13:13:35 UTC
I can confirm this bug. I had the following error when upgrading a box:
"""
Problem: both package rpmfusion-free-obsolete-packages-32-2.fc32.noarch and fedora-obsolete-packages-32-44.noarch obsolete gstreamer-plugins-ugly < 0.10.19-34
"""

fedora-obsolete-packages has no business obsoleting a package that was not provided in Fedora, especially if DNF errors out with such an issue and prevent the upgrade to run.

Comment 2 Miro Hrončok 2020-05-06 13:24:03 UTC
The problem was introduced in https://src.fedoraproject.org/rpms/fedora-obsolete-packages/c/4493c3676c97b330742fb0e4eb2ff894e21400ec?branch=master by a provenpackager. Maybe we should enable pull request access only?

Lets remove those.



> PS These 'Provides:' statements shouldn't be there, right?

Correct.


BTW I was not a avare that two packages cannot obsolete one package :/

Comment 3 Fedora Update System 2020-05-06 13:41:12 UTC
FEDORA-2020-b151af48ef has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b151af48ef

Comment 4 Miro Hrončok 2020-05-06 13:42:31 UTC
The update keeps obsoleting the older updates. I'd appreciate if you could actually test this and provide karma, so we can finally have a version that reaches stable.

Comment 5 Fedora Update System 2020-05-07 03:10:14 UTC
FEDORA-2020-b151af48ef has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.