Bug 182267 - drop static libs, cleanup xmms-config --libs output
drop static libs, cleanup xmms-config --libs output
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 10:27 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 05:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmms.spec.patch (1.67 KB, patch)
2006-02-21 10:27 EST, Rex Dieter
no flags Details | Diff
xmms-1.2.10-extra_libs.patch (439 bytes, patch)
2006-02-21 10:28 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2006-02-21 10:27:36 EST
Subject says it all
Comment 1 Rex Dieter 2006-02-21 10:27:37 EST
Created attachment 124957 [details]
xmms.spec.patch
Comment 2 Rex Dieter 2006-02-21 10:28:35 EST
Created attachment 124958 [details]
xmms-1.2.10-extra_libs.patch

drop gtk libs from `xmms-config --libs` output
Comment 3 Matthias Saou 2006-02-21 10:34:44 EST
What is the reason for dropping gtk libs from the --libs output? If it's a
valid one, you'll probably also want to remove the gtk+-devel requirement
from xmms-devel, right?
Comment 4 Rex Dieter 2006-02-21 10:44:00 EST
> What is the reason for dropping gtk libs from the --libs output?

Because they're extraneous and not needed?  (-:  
(At least as long as static libs are dropped)

xmms's headers contain
#include <gtk/gtk.h>
so I don't think droping -devel's Req: gtk+-devel is doable.
Comment 5 Matthias Saou 2006-02-21 11:07:00 EST
Hmmm, but if xmms' headers contain that, isn't it required to link against the
gtk+ libs, thus use the --libs output?
Comment 6 Rex Dieter 2006-02-21 12:38:43 EST
No.  libxmms.so.1 is (should-be) self-contained (ie, include no unresolved symbols).

ldd -r /usr/lib/libxmms.so.1
will show it already linked against those other libs.
Comment 7 Matthias Saou 2006-03-01 05:36:00 EST
BTW, I think your spec file patch was against the FC-4 package as I had already
removed the static lib during my last changes, and included a Patch12 to fix
crossfade :

* Mon Feb 13 2006 Matthias Saou <http://freshrpms.net/> 1:1.2.10-20
- Spec file cleanup.
- Include crossfade 0.3.9 patch.
- Remove very old x11amp obsoletes.
- Exclude static libraries, update devel summary and description for it.
- List all plugins directories in order to be aware of breakage if the
  libtool problem ever happens again.
- Fix post/postun scriplets.
- Remove xmms_logo.xpm and xmms_mini.xpm, they should be unused.
- Add libXt-devel to fullfill the "checking for X..." configure check.
- Add gettext-devel to make more configure checks happy.

Anyway, I'll include the other patch now.
Comment 8 Matthias Saou 2006-03-09 05:01:59 EST
The new package has been in Extras development for a while now. I'll probably
backport to FC4 soon after FC5 gets released, once it'll have gotten better
testing.

Note You need to log in before you can comment on or make changes to this bug.